Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602147 - 'GitNode' object has no attribute 'log'
'GitNode' object has no attribute 'log'
Status: CLOSED DUPLICATE of bug 580702
Product: Fedora EPEL
Classification: Fedora
Component: trac-git-plugin (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 05:23 EDT by Ferry Huberts
Modified: 2013-01-10 01:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-02 04:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (311 bytes, patch)
2010-06-09 05:23 EDT, Ferry Huberts
no flags Details | Diff

  None (edit)
Description Ferry Huberts 2010-06-09 05:23:19 EDT
Created attachment 422483 [details]
patch

Description of problem:
Sometimes an exception is thrown:
  'GitNode' object has no attribute 'log'

Version-Release number of selected component (if applicable):
trac-git-plugin 0.0.1-5.20090628svn3369.el5

How reproducible:
on some repositories always, on others never.

Steps to Reproduce:
1. browse source via trac on an affected repository
2.
3.
  
Actual results:
exception trace

Expected results:
normal source browsing

Additional info:
The exception is thrown because self.log is accessed in a GitNode object while that object has no log.

As it's a debug log only, we can easily get rid of it.
I wrote a patch to do just that
Comment 1 Ferry Huberts 2010-06-09 05:35:15 EDT
from what I can see now it is reproducible on repositories that use submodules
Comment 2 Ferry Huberts 2011-07-02 04:44:59 EDT

*** This bug has been marked as a duplicate of bug 580702 ***

Note You need to log in before you can comment on or make changes to this bug.