Bug 580968 - Pure virtual in gui::QSTreeItem::itemtype
Summary: Pure virtual in gui::QSTreeItem::itemtype
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pdfedit
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c5d9688e012cdc8ede06a0ab9d5...
Keywords:
: 558227 588159 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-09 16:03 UTC by Garrett Mitchener
Modified: 2010-06-10 19:10 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-10 19:10:17 UTC


Attachments (Terms of Use)
File: backtrace (60.82 KB, text/plain)
2010-04-09 16:03 UTC, Garrett Mitchener
no flags Details

Description Garrett Mitchener 2010-04-09 16:03:43 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: pdfedit
component: pdfedit
executable: /usr/bin/pdfedit
kernel: 2.6.32.10-90.fc12.x86_64
package: pdfedit-0.4.3-4.fc12
rating: 4
reason: Process /usr/bin/pdfedit was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)
How to reproduce: I was viewing and editing a couple of PDF files.  A lot of the commands don't seem to be working -- perhaps it's mis-packaged somehow?

Comment 1 Garrett Mitchener 2010-04-09 16:03:45 UTC
Created attachment 405578 [details]
File: backtrace

Comment 2 Orion Poplawski 2010-04-14 20:42:45 UTC
Can you install pdfedit 0.4.4.1 from here: http://koji.fedoraproject.org/koji/taskinfo?taskID=2115741

Can you reproduce the crash with a certain PDF?  If so, could you attach the PDF and describe how to reproduce it?

Can you describe more about which commands are not working?

Comment 3 James G. Sack 2010-04-20 00:05:09 UTC

How to reproduce
-----
1.Select some text
2.set font
3.

Comment 4 Orion Poplawski 2010-04-20 14:51:43 UTC
Can you reproduce with 4.4.1.1?  I can't.

yum -y --enablerepo=updates-testing upgrade pdfedit

Comment 5 Orion Poplawski 2010-04-21 16:44:21 UTC
#5  0x000000305ccb8daf in __cxxabiv1::__cxa_pure_virtual ()
    at ../../../../libstdc++-v3/libsupc++/pure.cc:50
No locals.
#6  0x0000000000489f56 in gui::QSTreeItem::itemtype() ()

Comment 6 Orion Poplawski 2010-04-21 16:52:20 UTC
*** Bug 558227 has been marked as a duplicate of this bug. ***

Comment 7 Orion Poplawski 2010-05-19 15:26:10 UTC
please try to reproduce with pdfedit 0.4.5 once it is pushed:

yum --enablerepo=updates-testing upgrade pdfedit 

http://admin.fedoraproject.org/updates/pdfedit-0.4.5-1.fc12

Comment 8 Karel Klíč 2010-05-25 09:13:29 UTC
*** Bug 588159 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-06-02 22:49:33 UTC
pdfedit-0.4.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pdfedit-0.4.5-1.fc12

Comment 10 Fedora Update System 2010-06-03 18:15:51 UTC
pdfedit-0.4.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pdfedit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pdfedit-0.4.5-1.fc12

Comment 11 Fedora Update System 2010-06-10 19:10:07 UTC
pdfedit-0.4.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.