Bug 580995 - enabled to set activationkey.basechannel to redhat default
Summary: enabled to set activationkey.basechannel to redhat default
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 530
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Keywords:
: 617745 (view as bug list)
Depends On:
Blocks: sat560-api
TreeView+ depends on / blocked
 
Reported: 2010-04-09 17:55 UTC by venky
Modified: 2018-12-03 17:09 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-10-01 21:44:33 UTC


Attachments (Terms of Use)

Description venky 2010-04-09 17:55:14 UTC
Description of problem:
enabled to set activationkey.basechannel to redhat default

Version-Release number of selected component (if applicable):
5.3

How reproducible:
python snippet:

activation_key_details = {'description':sys.argv[1],'base_channel_label':"none",'usage_limit':0,'universal_default':False}
client.activationkey.setDetails(sessionkey, "1-"+sys.argv[1],activation_key_details)

Steps to Reproduce:
1.Create a Dict in python with base channel_label set to none and tried with empty string.
2.
3.
  
Actual results:
Invalid base channel

Expected results:
Expect set details to be updated

Additional info:

Comment 1 Josep 'Pep' Turro Mauri 2011-04-29 09:54:38 UTC
*** Bug 617745 has been marked as a duplicate of this bug. ***

Comment 4 Tomáš Kašpárek 2013-05-15 11:35:50 UTC
fixed in spacewalk.git: 9327300aa9718d168b4393fe32b9003ddd10e786

'base_channel_label':"none"
and
'base_channel_label':""

can now be used for resetting base channel associated with activation key to default

Comment 7 Tomáš Kašpárek 2013-09-10 15:14:18 UTC
updated api doc in spacewalk.git: 9212196c0d4758d22ddb2dbaedbb8239285fb9cd

Comment 9 Tomáš Kašpárek 2013-09-11 07:16:49 UTC
fixed typo + clarified message - spacewalk.git: 2a749f1ff5f442ddd095e40fd44809f26eaaff6c

Comment 13 Martin Korbel 2013-10-01 13:47:25 UTC
Stage validated with Satellite-5.6.0-RHEL5-re20130926.0-x86_64.

Steps to reproduce in comment 12

Comment 14 Clifford Perry 2013-10-01 21:40:10 UTC
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html


Note You need to log in before you can comment on or make changes to this bug.