Bug 617745 - activationkey.setDetails cannot set back an empty base_channel_label
activationkey.setDetails cannot set back an empty base_channel_label
Status: CLOSED DUPLICATE of bug 580995
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-07-23 16:35 EDT by Jérôme Fenal
Modified: 2011-04-29 05:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 05:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jérôme Fenal 2010-07-23 16:35:50 EDT
Description of problem:

activationkey.setDetails cannot set back an empty base_channel_label to have
"RHN Satellite default" functionnality
End in error :
Error encountered calling activationkey.setDetails : Fault returned
from XML RPC Server, fault code -211: redstone.xmlrpc.XmlRpcFault:
Invalid channel

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

No mean to reset an activation key to have "RHN Satellite default" behaviour (eg. choose the right base channel according to registration results).

Expected results:
Allow for setting a special base_channel_label content in activationkey.setDetails to reset to default behaviour.
Ideally an empty string (won't clash with user defined channel label), or a well known string such as "default", but this may clash if a user has named a channel "default".

Additional info:
Comment 1 Josep 'Pep' Turro Mauri 2011-04-29 05:54:38 EDT

*** This bug has been marked as a duplicate of bug 580995 ***

Note You need to log in before you can comment on or make changes to this bug.