Bug 58146 - dhcpcd still remove IFF_MULTICAST from interface flags
dhcpcd still remove IFF_MULTICAST from interface flags
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 17:23 EST by Tim Wright
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 18:46:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to client.c to fix interface manipulation. (1.58 KB, patch)
2002-01-15 18:42 EST, Tim Wright
no flags Details | Diff

  None (edit)
Description Tim Wright 2002-01-09 17:23:40 EST
Description of Problem: This is ongoing from bug #55093. I just took the rawhide 
RPM which claims to have fixed bug #55093, and it still fails turning off multicast for 
the interface in question. Looking at the code, this makes sense because at line 
1175, IFF_MULTICAST is added to the interface flags, but almost immediately 
after at line 1206 in the broadcast loop, it's missing again :-(

I'm not sure, but it strikes me that it would be better to use SIOCGIFFLAGS first 
and save such things as the multicast state rather than unconditionally overwriting 
the flags.


Version-Release number of selected component (if applicable):
dhcpcd-1.3.21-pl2

How Reproducible:
Totally.

Steps to Reproduce:
1.  Install rawhide dhcpcd
2. Bring up an interface using dhcpcd
3. Notice that multicast is no longer set on the interface

Actual Results:
Interface does not show multicast.

Expected Results:
Interface should show multicast.

Additional Information:
 This worked in Red Hat 7.1. The wierd part is that the 1.3.18pl8 code doesn't 
seem to bother with the IFF_MULTICAST flag at all, yet it doesn't get reset. Is this 
a change in the library/kernel code that's now killing the flag ?
Comment 1 Tim Wright 2002-01-15 18:42:47 EST
Created attachment 42516 [details]
Patch to client.c to fix interface manipulation.
Comment 2 Tim Wright 2002-01-15 18:46:38 EST
Attached patch that fixes the problem with the flags getting reset, at least in
my testing. This patch is against the virgin dhcpcd-1.3.21pl2 code.

Regards,

Tim
Comment 3 Elliot Lee 2002-03-08 11:02:32 EST
applied in my package, will submit upstream as well

Note You need to log in before you can comment on or make changes to this bug.