Bug 58158 - efibootmgr can't write label into NVRAM.
Summary: efibootmgr can't write label into NVRAM.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elilo   
(Show other bugs)
Version: 7.2
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
: 64534 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 12:33 UTC by Shinya Narahara
Modified: 2014-03-17 02:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 18:08:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shinya Narahara 2002-01-10 12:33:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
When the installation finished, efibootmgr command outputs some error on the screen,
and the efi boot menu is never changed.
Also the command /usr/sbin/efibootmgr can't do so.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat 7.2 for IA-64.
2.
3.
	

Actual Results:  Error displayed below:
efibootmgr: write_variable(): can't open /proc/efi/var/Efi-47c7b226-c42a-11d2-8e57-00a0c969723b


Expected Results:  exit normally and add label "Red Hat Linux" into EFI NVRAM.

Additional info:

The file named "/proc/efi/var/Efi-47c7b226-c42a-11d2-8e57-00a0c969723b" is hard coded in
efibootmgr-0.3.x, however we don't have this file on our test machie. The new one,
eifbootmgr-0.4.0-test4, doesn't have this name in its sourcecode. And we've confirmed that the
0.4.0-test4 works fine. Refer http://domsch.com/linux/ia64/efibootmgr/.

Maybe this issue depends on EFI version. Our test machine is Intel BigSur(IA-64 800MHz x2),
which has EFI version 1.02, 1.01 sal and 1.01 pal. BigSur that has older EFI, has /proc/efi/var/
Efi-47c7b226-c42a-11d2-8e57-00a0c969723b file certainly.

So we recommend to updete efibootmgr(in elilo package) as soon as possible,
newer EFI really needs it.

Comment 1 Bill Nottingham 2002-05-07 15:51:08 UTC
*** Bug 64534 has been marked as a duplicate of this bug. ***

Comment 2 Matt Domsch 2003-02-13 18:08:06 UTC
AS2.1 IPF contains efibootmgr 0.4.0 fix.  Closing.
Newer efibootmgr RPMs available on domsch.com if needed apart from AS2.1 IPF.


Note You need to log in before you can comment on or make changes to this bug.