Bug 64534 - efibootmgr writes fail with some BIOSs, update to 0.4.0
efibootmgr writes fail with some BIOSs, update to 0.4.0
Status: CLOSED DUPLICATE of bug 58158
Product: Red Hat Linux
Classification: Retired
Component: elilo (Show other bugs)
7.2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 11:06 EDT by Matt Domsch
Modified: 2014-03-16 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-07 11:06:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2002-05-07 11:06:28 EDT
Description of Problem:
The elilo RPM includes efibootmgr 0.3.x.  This version has a dependency on the 
existence of an EFI variable named Efi-(some-big-guid).  Newer BIOSs from Intel 
may not include this particular variable, hence all writes performed by 
efibootmgr fail.  0.4.0 addresses this problem by removing the dependency on 
any particular EFI variable name.

Version-Release number of selected component (if applicable):
elilo-3.1-2

How Reproducible:
Always with Dell PowerEdge 7150 BIOS A03, or any EFI 1.1-based BIOS, where the 
particular EFI variable listed does not exist.

Steps to Reproduce:
1. Install 7.2 retail on a PE7150 with BIOS A03
2. See that no "Red Hat Linux" boot manager entry is created, and that all 
write calls to efibootmgr fail because it cannot find a file named Efi-*.


Actual Results:
No "Red Hat Linux" boot manager entry is created.  EFI Boot Manager is not 
modified.

Expected Results:
EFI Boot Manager would be updated as expected.

Additional Information:
efibootmgr v0.4.0 is posted at http://domsch.com/linux/ia64/efibootmgr/.  This 
is not a critical bug fix, but should be fixed for any future IA-64 releases, 
and time-permitting and dependent on number of customers with IA-64, an erratum 
(I leave this entirely up to Red Hat to decide).  Dell will be replacing the 
efibootmgr binary as shipped in elilo-3.1-2 with a new binary, and placing the 
0.4.0 source code in /dell, on all factory-installed systems.
Comment 1 Bill Nottingham 2002-05-07 11:51:13 EDT

*** This bug has been marked as a duplicate of 58158 ***

Note You need to log in before you can comment on or make changes to this bug.