Bug 581768 - pxe installation of RHEL-3.9-32 hung
pxe installation of RHEL-3.9-32 hung
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5.z
All Linux
low Severity medium
: rc
: ---
Assigned To: Glauber Costa
Virtualization Bugs
: Triaged
: 654551 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier3 654551 664349
  Show dependency treegraph
 
Reported: 2010-04-13 03:55 EDT by Amos Kong
Modified: 2015-05-24 20:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 654551 664349 (view as bug list)
Environment:
Last Closed: 2011-03-29 09:24:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Packages installation, it can be completed 100% (13.53 KB, image/png)
2010-04-13 03:57 EDT, Amos Kong
no flags Details
After packages installation, guest hung (9.55 KB, image/png)
2010-04-13 03:57 EDT, Amos Kong
no flags Details
kickstart file of rhel39.32 (792 bytes, application/octet-stream)
2010-11-25 22:15 EST, Amos Kong
no flags Details
Trace output when installation hangs (4.07 MB, application/octet-stream)
2011-03-28 02:20 EDT, Amos Kong
no flags Details

  None (edit)
Description Amos Kong 2010-04-13 03:55:21 EDT
Description of problem:
Installation of RHEL-3.9-32 hung. Formating disk and package installation are all completed.
And installation of RHEL-3.9-64 is ok.


Version-Release number of selected component (if applicable):
# uname -a
Linux amd-2427-32-2.englab.nay.redhat.com 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

# rpm -qa |grep kvm
kvm-83-170.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-qemu-img-83-170.el5
kvm-debuginfo-83-170.el5
kmod-kvm-83-170.el5
kvm-tools-83-170.el5

How reproducible:
always

Steps to Reproduce:
1. install RHEL-3.9-32 guest

  
Actual results:
installation hung

Expected results:
installation can complete

Additional info:
commandline:
# /root/autotest/client/tests/kvm/qemu -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-3.9-32.raw,if=ide,cache=writethrough,boot=on -net nic,vlan=0,model=e1000,macaddr=00:11:22:33:50:01 -net user,vlan=0 -m 33792 -smp 12 -drive file=/root/autotest/client/tests/kvm/isos/linux/RHEL3.9-i386-DVD.iso,index=2,media=cdrom -soundhw ac97 -fda /root/autotest/client/tests/kvm/images/floppy.img -tftp /root/autotest/client/tests/kvm/images/tftpboot -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n -redir tcp:5000::22 -redir tcp:5001::12323 -vnc :0
Comment 1 Amos Kong 2010-04-13 03:57:09 EDT
Created attachment 406171 [details]
Packages installation, it can be completed 100%
Comment 2 Amos Kong 2010-04-13 03:57:48 EDT
Created attachment 406172 [details]
After packages installation, guest hung
Comment 3 Amos Kong 2010-04-13 06:49:29 EDT
This bug can also be reproduced when using this command line.

# qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-3.9-32.qcow2,if=ide,cache=off,boot=on -net nic,vlan=0,model=e1000,macaddr=00:11:22:33:0f:a9 -net user,vlan=0 -m 33792 -smp 12 -drive file=/root/autotest/client/tests/kvm/isos/linux/RHEL3.9-i386-DVD.iso,index=2,media=cdrom -fda /root/autotest/client/tests/kvm/images/floppy.img -tftp /root/autotest/client/tests/kvm/images/tftpboot -bootp /pxelinux.0 -boot n -vnc :0
Comment 4 Amos Kong 2010-04-14 11:35:28 EDT
Kickstart can be found here:
http://github.com/ehabkost/autotest/tree/master/client/tests/kvm/unattended/

The problem happens because it's simply not possible to bring the
network up at post install stage so the install can communicate with
the host to respond that its installation finished.

It may be an anaconda bug on that particular RHEL version.
Comment 6 Suqin Huang 2010-06-11 22:49:36 EDT
rhel4 installion also hang 

qemu: qemu-img-0.12.1.2-2.72.el6.x86_64
kernel: 2.6.32-33.el6.x86_64

command: 
 /usr/libexec/qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/usr/client/tests/kvm/images/RHEL-4.8-32.qcow2,if=ide,cache=none,boot=on,aio=native -net nic,vlan=0,model=e1000,macaddr=02:30:7C:AF:37:cd -net user,vlan=0 -m 2048 -smp 2 -drive file=/usr/isos/linux/RHEL4.8-i386-AS-DVD.iso,index=2,media=cdrom -soundhw ac97 -fda /usr/images/floppy.img -tftp /usr/images/tftpboot -redir tcp:5000::22 -redir tcp:5002::12323 -vnc :0 -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n -serial unix:/tmp/serial-20100611-191801-1ruL,server,nowait
Comment 7 Dor Laor 2010-11-25 05:59:22 EST
Is it reproducible without qemu's tftp server?
1. With real rhel3 iso
2. With real pxe server
Comment 8 Amos Kong 2010-11-25 22:14:13 EST
(In reply to comment #7)
> Is it reproducible without qemu's tftp server?
> 1. With real rhel3 iso

result: PASS ( manual)

cmdline: qemu-kvm -name vm1 -monitor unix:/tmp/monitor-humanmonitor1-20101124-180901-LAjn,server,nowait -serial unix:/tmp/serial-20101124-180901-LAjn,server,nowait -drive file=/home/devel/autotest-devel/client/tests/kvm/images/RHEL-3.9-32-virtio.qcow2,index=0,if=ide,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=e1000,macaddr=9a:72:41:20:f4:18 -net tap,vlan=0,ifname=t0-180901-LAjn,script=/home/devel/autotest-devel/client/tests/kvm/scripts/qemu-ifup-vbr0,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -drive file=/home/devel/autotest-devel/client/tests/kvm/isos/linux/RHEL3.9-i386-DVD.iso,media=cdrom,index=2 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -no-kvm-pit-reinjection -boot d

> 2. With real pxe server

result: FAIL (kickstart) (will attach the kickstar file)

cmdline: /home/devel/autotest-devel/client/tests/kvm/qemu -name 'vm1' -monitor unix:'/tmp/monitor-humanmonitor1-20101124-180901-LAjn',server,nowait -serial unix:'/tmp/serial-20101124-180901-LAjn',server,nowait -drive file='/home/devel/autotest-devel/client/tests/kvm/images/RHEL-3.9-32-virtio.qcow2',index=0,if=ide,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=e1000,macaddr='9a:72:41:20:f4:18' -net tap,vlan=0,ifname='t0-180901-LAjn',script='/home/devel/autotest-devel/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 2048 -smp 2,cores=1,threads=1,sockets=2 -drive file='/home/devel/autotest-devel/client/tests/kvm/isos/linux/RHEL3.9-i386-DVD.iso',media=cdrom,index=2  -cpu qemu64,+sse2 -soundhw ac97   -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -no-kvm-pit-reinjection -boot n
Comment 9 Amos Kong 2010-11-25 22:15:53 EST
Created attachment 462989 [details]
kickstart file of rhel39.32
Comment 10 Dor Laor 2010-11-28 05:21:06 EST
Glauber can you please have a look?
Amos, does it work over rhel6 host?
Comment 11 Amos Kong 2010-11-28 21:25:41 EST
(In reply to comment #10)
> Glauber can you please have a look?

> Amos, does it work over rhel6 host?

doesn't work, the phenomenon is same.
Comment 14 Don Dutile 2010-12-08 10:36:52 EST
Has another emulated NIC been tried, i.e., rtl8139 ?
Comment 15 Amos Kong 2010-12-08 21:30:51 EST
(In reply to comment #14)
> Has another emulated NIC been tried, i.e., rtl8139 ?

can reproduced.
Comment 18 Gleb Natapov 2010-12-15 06:14:13 EST
*** Bug 654551 has been marked as a duplicate of this bug. ***
Comment 20 RHEL Product and Program Management 2011-01-11 15:44:37 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 21 RHEL Product and Program Management 2011-01-11 17:50:40 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 26 Amos Kong 2011-03-28 02:20:30 EDT
Created attachment 488084 [details]
Trace output when installation hangs

Note You need to log in before you can comment on or make changes to this bug.