Bug 581794 - D-Bus error mishandling in ifcfg-rh
D-Bus error mishandling in ifcfg-rh
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 584619 585399 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-13 05:07 EDT by Frank Murphy
Modified: 2013-01-10 00:49 EST (History)
7 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.0-7.git20100422.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 02:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Install crash (62.89 KB, application/octet-stream)
2010-04-13 05:07 EDT, Frank Murphy
no flags Details
Crash Report (62.89 KB, text/plain)
2010-04-13 05:22 EDT, Frank Murphy
no flags Details
Network Manager debug output (17.06 KB, text/plain)
2010-04-17 16:43 EDT, Owen Taylor
no flags Details
Samsung N150 traceback (69.22 KB, text/plain)
2010-04-21 07:18 EDT, Nathan Thomas
no flags Details

  None (edit)
Description Frank Murphy 2010-04-13 05:07:46 EDT
Created attachment 406180 [details]
Install crash

Description of problem: linstal-to-hd crash


Version-Release number of selected component (if applicable):
?


How reproducible: always


Steps to Reproduce:
1. 
http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/xfce/x86_64-20100411.16.iso
2. install to hd
3.
  
Actual results: exception 


Expected results: install to hd


Additional info: HD contains shrunk Win 7 64bit.
Comment 1 Frank Murphy 2010-04-13 05:22:24 EDT
Created attachment 406187 [details]
Crash Report

reattached as test file.
Comment 2 Chris Lumens 2010-04-13 09:28:52 EDT
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/anaconda/isys.py", line 320, in getNetworkDeviceCount
    nm = bus.get_object(NM_SERVICE, NM_MANAGER_PATH)
  File "/usr/sbin/anaconda", line 644, in requiresNetworkInstall
    numNetDevs = isys.getNetworkDeviceCount()
  File "/usr/lib/anaconda/iw/welcome_gui.py", line 55, in getNext
    if self.anaconda.requiresNetworkInstall():
  File "/usr/lib/anaconda/gui.py", line 1309, in nextClicked
    rc = self.currentWindow.getNext ()
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
Comment 3 Chris Lumens 2010-04-13 09:31:41 EDT
Is NetworkManager running?
Comment 4 Frank Murphy 2010-04-13 09:44:41 EDT
(In reply to comment #3)
> Is NetworkManager running?    

Yes.
This reply is from the running Live boot.
Comment 5 Owen Taylor 2010-04-17 16:34:56 EDT
What I was seeing for this is that NetworkManager is running until I click Next in anaconda, then NetworkManager crashesd. It happened reliably a bunch of times, then didn't happen when I was running dbus-monitor to try and figure out what was going on. When it crashed with 'NetworkManager --no-daemon' the backtrace indicated it was a D-Bus exception triggered by the NetworkManager code trying to send an error message back.
Comment 6 Owen Taylor 2010-04-17 16:43:53 EDT
Created attachment 407309 [details]
Network Manager debug output

OK, so when I installed debuginfo packages, I was able to get a more informative output. Output from NetworkManager --no-daemon attached.

[ The crash of NetworkManager actually occurs when anaconda is started, it's only the anaconda crash that happens when you hit Next ]
Comment 7 Nathan Thomas 2010-04-21 07:18:46 EDT
Created attachment 408044 [details]
Samsung N150 traceback

I also encountered this bug on my Samsung N150 netbook. The netbook uses a Realtek 8192E wireless card and a Ralink ethernet card. Traceback attached.
Comment 8 Dan Williams 2010-04-22 14:24:21 EDT
*** Bug 584619 has been marked as a duplicate of this bug. ***
Comment 9 Dan Williams 2010-04-22 16:32:58 EDT
This is both a dbus-glib bug and an NM bug.  We'll work around it in NM since NM's ifcfg-rh system settings plugin is doing something stupid to trigger this in dbus-glib.

For reference, the upstream dbus-glib bug is:

https://bugs.freedesktop.org/show_bug.cgi?id=27799
Comment 10 Fedora Update System 2010-04-22 19:54:59 EDT
NetworkManager-0.8.0-7.git20100422.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-7.git20100422.fc13
Comment 11 Fedora Update System 2010-04-23 02:03:09 EDT
NetworkManager-0.8.0-7.git20100422.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Jesse Keating 2010-04-23 19:26:33 EDT
*** Bug 585399 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.