Bug 581887 - Graphical boot does not reach the login screen.
Summary: Graphical boot does not reach the login screen.
Status: CLOSED DUPLICATE of bug 577789
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-13 13:53 UTC by Björn Persson
Modified: 2010-04-16 14:11 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-04-16 14:11:13 UTC


Attachments (Terms of Use)
X server log with drm.debug=15 (8.01 KB, text/plain)
2010-04-13 13:53 UTC, Björn Persson
no flags Details
/var/log/messages with drm.debug=15 (51.45 KB, text/plain)
2010-04-13 13:56 UTC, Björn Persson
no flags Details
/var/log/dmesg with drm.debug=15 (122.74 KB, text/plain)
2010-04-13 13:57 UTC, Björn Persson
no flags Details
/var/log/Xorg.0.log with nomodeset (77.10 KB, text/plain)
2010-04-13 13:59 UTC, Björn Persson
no flags Details

Description Björn Persson 2010-04-13 13:53:01 UTC
Created attachment 406243 [details]
X server log with drm.debug=15

Description of problem:
The graphical boot process stops after the Fedora logo is filled.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-2.20100218git2964702.fc13.x86_64

How reproducible:
two times out of two

Steps to Reproduce:
http://fedoraproject.org/wiki/QA:Testcase_nouveau_basic
  
Actual results:
The Fedora logo gets filled from lower left to upper right, a halo appears and fades, and then nothing more happens on the screen. I can access the system by SSH though. Only the graphics is broken.

Expected results:
a login screen

Additional info:
It has worked before. This problem started after I installed a huge bunch of updates in preparation for the Nouveau test day.

Smolt profile: http://www.smolts.org/client/show/pub_88cd7ab2-c7c0-46b9-9a91-e7687128a21c
There are files in /etc/xorg.conf.d but no xorg.conf.

Comment 1 Björn Persson 2010-04-13 13:56:11 UTC
Created attachment 406245 [details]
/var/log/messages with drm.debug=15

Comment 2 Björn Persson 2010-04-13 13:57:16 UTC
Created attachment 406246 [details]
/var/log/dmesg with drm.debug=15

Comment 3 Björn Persson 2010-04-13 13:59:24 UTC
Created attachment 406248 [details]
/var/log/Xorg.0.log with nomodeset

With nomodeset I get a login screen but with a lower resolution than it should be.

Comment 4 Björn Persson 2010-04-13 22:48:43 UTC
If I don't add "nomodeset" but instead remove "rhgb", then the system boots OK with the correct resolution.

Comment 5 Ben Skeggs 2010-04-14 00:33:15 UTC
I'm wondering if you're seeing an issue I seen after some recent updates.  If you boot with unmodified default boot options, except for an appended "3", and the login at the graphical console and run "init 5", do things work as expected?

Comment 6 Björn Persson 2010-04-14 11:16:59 UTC
Assuming s/graphical/text/, that works except that keypresses aren't echoed on tty1 so I have to type the username blindly and "Password:" is printed to the right of "login:" instead of below. After I've logged in keypresses are echoed as usual. On tty2 I don't see this quirk.

Anyway, yes, "init 5" works as expected.

Comment 7 Ben Skeggs 2010-04-14 22:52:49 UTC
Ok.  Can you check https://bugzilla.redhat.com/show_bug.cgi?id=577789, I'd say it's likely the same issue.

Comment 8 Björn Persson 2010-04-16 14:11:13 UTC
gdm-2.29.92-6.fc13 fixed this.

I filed bug 583025 about the problem with "nomodeset".

*** This bug has been marked as a duplicate of bug 577789 ***


Note You need to log in before you can comment on or make changes to this bug.