Bug 5826 - ispell does not work with the ispell-french dictionary
ispell does not work with the ispell-french dictionary
Status: CLOSED DUPLICATE of bug 4958
Product: Red Hat Linux
Classification: Retired
Component: ispell (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-11 04:46 EDT by marc.lefranc
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-26 13:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marc.lefranc 1999-10-11 04:46:14 EDT
1045 $ ispell -d francais test.ispell
Illegal format hash table /usr/lib/ispell/francais.hash -
expected magic2 0x9602, got 0x45

This must be a problem with ispell, not with the dictionary
as I had installed the vary same francais.hash on my 6.0
system, and it was working fine with the 6.0 ispell package.
Comment 1 marc.lefranc 1999-10-22 08:47:59 EDT
I finally found out what was happening, and when logging to this site,
I doscover that this is in fact the same thing as for bugs  5874 and
6190. Because $LANG did not contain fr, the hash files were not
installed, thus leaving around the old files from my own installation.
Unsetting LINGUAS or setting it to fr befire reinstalling solved the
problem. IMHO, this should be classified as a (small) bug in rpm
because failing to install the only non-doc files of a package because
of an incorrect variable should at least be notified by a warning
message. If someone wants to install ispell-french, it is likely that
he really wants a french dictionnary.
Also, there should be an option to rpm -V to warn about non-installed
files.
Comment 2 Jeff Johnson 1999-10-26 13:45:59 EDT
*** This bug has been marked as a duplicate of 4958 ***

Note You need to log in before you can comment on or make changes to this bug.