Bug 4958 - Files not installing
Files not installing
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: ispell (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 5826 5874 6365 6396 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-07 14:39 EDT by osman
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-08 11:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description osman 1999-09-07 14:39:08 EDT
In the Dutch package one can see the files but they aren't
beeing installed.
Neither with INSTALL nor with UPGRADE.
I use mc to navigate through the RPM's...
Comment 1 Jeff Johnson 1999-09-08 11:44:59 EDT
The dictionaries are currently mareked as locale specific (i.e they're
marked as %lang(nl)) That means the files will not be installed
unless that locale is marked for installation.

Reinstall with
 LINGUAS="nl:en" rpm -U --force ispell-dutch-3.1.20-22.i386.rpm
Comment 2 Bill Nottingham 1999-10-12 11:18:59 EDT
*** Bug 5874 has been marked as a duplicate of this bug. ***


Hand-installing the ispell and ispell-greek packages
from the 6.1 distro in a 6.0 system misses the files from
ispell-greek-3.1.20-22.i386.rpm. Here's the story:

# rpm -e ispell                // remove 6.0 ispell
# rpm -ivh ispell-3.1.20-22.i386.rpm
# rpm -ivh ispell-greek-3.1.20-22.i386.rpm

Everything seems to be ok, then...

# rpm -V ispell

no error messages

# rpm -V ispell-greek

no error messages

but /usr/lib/ispell/ellhnika.{aff,hash} ARE missing, as
witnessed by

# rpm -Vp ispell-greek-3.1.20-22.i386.rpm
missing     /usr/lib/ispell/ellhnika.aff
missing     /usr/lib/ispell/ellhnika.hash

So, is this a bug in the greek spelling package or in the
rpm program ? Why do I get different results using the
-V  and -Vp  switches with rpm ?

rpm version is    rpm-3.0.2-6.0

Thank you in advange.
GNT
Comment 3 Jeff Johnson 1999-10-26 13:44:59 EDT
*** Bug 6365 has been marked as a duplicate of this bug. ***

when using RPM to install ispell-danish.3,1.20-22.i386.rpm
(or the ispell-polish....) from the RH-6.1 CD (download
version)
the 'word' files is NOT installed in the directory
(/usr/lib/ispell), but RPM don't report any errors in the
instalation.
It looks like the instalation is OK, the package is
registred as 'installed' (RPM -qa| grep ispell), but still.
no word-datafile.
Comment 4 Jeff Johnson 1999-10-26 13:45:59 EDT
*** Bug 5826 has been marked as a duplicate of this bug. ***

1045 $ ispell -d francais test.ispell
Illegal format hash table /usr/lib/ispell/francais.hash -
expected magic2 0x9602, got 0x45

This must be a problem with ispell, not with the dictionary
as I had installed the vary same francais.hash on my 6.0
system, and it was working fine with the 6.0 ispell package.

------- Additional Comments From Marc.Lefranc@univ-lille1.fr  10/22/99 08:47 -------
I finally found out what was happening, and when logging to this site,
I doscover that this is in fact the same thing as for bugs  5874 and
6190. Because $LANG did not contain fr, the hash files were not
installed, thus leaving around the old files from my own installation.
Unsetting LINGUAS or setting it to fr befire reinstalling solved the
problem. IMHO, this should be classified as a (small) bug in rpm
because failing to install the only non-doc files of a package because
of an incorrect variable should at least be notified by a warning
message. If someone wants to install ispell-french, it is likely that
he really wants a french dictionnary.
Also, there should be an option to rpm -V to warn about non-installed
files.
Comment 5 Jeff Johnson 1999-10-27 10:51:59 EDT
*** Bug 6396 has been marked as a duplicate of this bug. ***

The files svenska.aff and svenska.hash are listed as
present in the rpm, but are not being installed in
/usr/lib/ispell.

Note You need to log in before you can comment on or make changes to this bug.