Bug 582820 - Exception: device-mapper: create ioctl failed: Périphérique ou ressource occupé
Summary: Exception: device-mapper: create ioctl failed: Périphérique ou ressource occupé
Keywords:
Status: CLOSED DUPLICATE of bug 583484
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyblock
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:5d962ee5dbcf459d6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-15 21:02 UTC by mounirvonmuller
Modified: 2010-07-23 19:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-23 19:28:02 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (243.08 KB, text/plain)
2010-04-15 21:02 UTC, mounirvonmuller
no flags Details
Attached traceback automatically from anaconda. (103.94 KB, text/plain)
2010-05-01 02:58 UTC, Liang Suilong
no flags Details

Description mounirvonmuller 2010-04-15 21:02:10 UTC
The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/block/__init__.py", line 33, in dm_log
    raise Exception, message
  File "/usr/lib64/python2.6/site-packages/block/maps.py", line 186, in create
    self.map = _dm.map(name = self.name, table = self.table)
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 770, in buildParts
    map.create()
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 814, in activate
    self.buildParts()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1656, in handleUdevDMRaidMemberFormat
    rs.activate(mknod=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1782, in handleUdevDeviceFormat
    self.handleUdevDMRaidMemberFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1278, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 972, in addUdevDMDevice
    self.addUdevDevice(new_info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1234, in addUdevDevice
    device = self.addUdevDMDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 972, in addUdevDMDevice
    self.addUdevDevice(new_info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1234, in addUdevDevice
    device = self.addUdevDMDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1936, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 377, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: device-mapper: create ioctl failed: Périphérique ou ressource occupé

Comment 1 mounirvonmuller 2010-04-15 21:02:15 UTC
Created attachment 406940 [details]
Attached traceback automatically from anaconda.

Comment 2 Liang Suilong 2010-05-01 02:58:33 UTC
Created attachment 410635 [details]
Attached traceback automatically from anaconda.

Comment 3 Hans de Goede 2010-07-23 19:28:02 UTC

*** This bug has been marked as a duplicate of bug 583484 ***


Note You need to log in before you can comment on or make changes to this bug.