Bug 583484 - installer reports unhandled exceptions after selecting drives
installer reports unhandled exceptions after selecting drives
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pyblock (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 582820 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-18 15:17 EDT by Reuben W. Perelman
Modified: 2010-07-23 15:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 584272 (view as bug list)
Environment:
Last Closed: 2010-05-03 16:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error log (91.67 KB, text/plain)
2010-04-18 15:17 EDT, Reuben W. Perelman
no flags Details
Updated pyblock device.py fixing this. (29.74 KB, text/plain)
2010-04-20 04:55 EDT, Hans de Goede
no flags Details

  None (edit)
Description Reuben W. Perelman 2010-04-18 15:17:10 EDT
Created attachment 407441 [details]
error log

Description of problem:
After booting up the Fedora 13 Beta, KDE Live CD I start anaconda. After selecting the drive I want to install to, the installer appears to search the drive and than reports an unhandled exception.
Comment 1 Hans de Goede 2010-04-19 09:17:55 EDT
Thanks for the report. The reason behind this problem is a bit technical: parted and kpartx don't seem to see eye to eye wrt what your partition table looks like.

Can you please do the following, as root in a terminal:
dmsetup table

And paste the output here, then start python:
python

And at the >>> prompt type the following commands:

import parted
dev = parted.Device(path="/dev/mapper/pdc_cabbjieh")
disk = parted.Disk(device=dev)
for p in disk.partitions:
    print p.geometry


You can simply cut and paste the above commands to the python prompt, you need to finish with an empty line, so if the prompt is ... after typing these commands simply press enter.

Now copy and paste the output of these python commands here (as a comment to this bug) too.

Once I have this info I can hopefully figure out what is going on.
Comment 2 Reuben W. Perelman 2010-04-19 18:18:59 EDT
[root@localhost ~]# dmsetup table
pdc_cabbjieh: 0 490234624 linear 8:32 0
pdc_cabbjiehp5: 0 215817147 linear 253:0 274406328
live-osimg-min: 0 6291456 snapshot 7:3 7:1 P 8
live-rw: 0 6291456 snapshot 7:3 7:4 P 8
pdc_cabbjiehp2: 0 2 linear 253:0 274406265
pdc_cabbjiehp1: 0 274406202 linear 253:0 63

parted.Geometry instance --
  start: 63  end: 274406264  length: 274406202
  device: <parted.device.Device object at 0x9e8090>  PedGeometry: <_ped.Geometry object at 0x9e1f10>
parted.Geometry instance --
  start: 274406265  end: 490223474  length: 215817210
  device: <parted.device.Device object at 0x9e1ed0>  PedGeometry: <_ped.Geometry object at 0x9e1e50>
parted.Geometry instance --
  start: 274406328  end: 490223474  length: 215817147
  device: <parted.device.Device object at 0x9e83d0>  PedGeometry: <_ped.Geometry object at 0x9e8290>
Comment 3 Hans de Goede 2010-04-20 04:48:54 EDT
Reuben,

Thanks, that is very useful information. This actually is a pyblock issue, so I've changed the component.

I'll attach an updated device.py. Can you please:
1) Boot from the F-13 beta livecd
2) Replace /usr/lib/python2.6/site-packages/block/device.py
   with the attached device.py, note if you're doing a 64 bit install the path
   is /usr/lib64/python2.6/site-packages/block/device.py
3) Start the installer from the livecd desktop and try to install,
   this should work now

Thanks,

Hans

p.s.

Making this an F13Blocker as it breaks installation on any dmraid using BIOS RAID (so not Intel BIOS RAID) system with an extended partition.
Comment 4 Hans de Goede 2010-04-20 04:55:48 EDT
Created attachment 407767 [details]
Updated pyblock device.py fixing this.
Comment 5 Fedora Update System 2010-04-20 05:31:17 EDT
python-pyblock-0.47-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-pyblock-0.47-1.fc13
Comment 6 Reuben W. Perelman 2010-04-20 08:57:27 EDT
Okay, the updated file allowed me to install the beta.
Comment 7 Hans de Goede 2010-04-20 09:06:00 EDT
(In reply to comment #6)
> Okay, the updated file allowed me to install the beta.    

Great, thanks for testing! Could you perhaps give a positive vote to the updated pyblock package with this fix:
http://admin.fedoraproject.org/updates/python-pyblock-0.47-1.fc13

Thanks,

Hans
Comment 8 Fedora Update System 2010-04-20 22:23:55 EDT
python-pyblock-0.47-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-pyblock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-pyblock-0.47-1.fc13
Comment 9 Adam Williamson 2010-04-23 15:33:21 EDT
Reuben: thanks for the feedback! Just a note for any future cases: if you have a fedoraproject.org (FAS) account, you can log in to Bodhi with that before leaving your feedback on updates. If you do that, your feedback gets counted in the update's 'score', which can help it get pushed faster. If you could do that for this update it would also be great.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2010-04-23 15:34:26 EDT
Discussed at today's blocker meeting: we agree this is a blocker, many thanks to Hans for including the rationale in his awesome comments. I will test install works here with the updated python-pyblock package and +1 the update if so.
Comment 11 Adam Williamson 2010-05-03 16:36:36 EDT
The updated python-pyblock has been pushed to stable, Reuben confirmed the fix, so closing this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Hans de Goede 2010-07-23 15:28:02 EDT
*** Bug 582820 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.