Bug 582968 - kio_sftp does not work - "Error. Out of memory"
Summary: kio_sftp does not work - "Error. Out of memory"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-runtime
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 581342 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-16 10:12 UTC by Michal Hlavinka
Modified: 2010-04-30 17:18 UTC (History)
10 users (show)

Fixed In Version: kdebase-runtime-4.4.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-30 17:11:58 UTC
Type: ---


Attachments (Terms of Use)

Description Michal Hlavinka 2010-04-16 10:12:22 UTC
Description of problem:
kde sc 4.4.2 in F13 have broken sftp support. I did not test sftp support before upgrade, so can't tell if it works in 4.4.1, but I was using sftp on monday in F-12 with 4.4.1 (at least - I always upgrade to kde packages in koji)

Version-Release number of selected component (if applicable):
kdebase-runtime-libs-4.4.2-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1.open any sftp location in krusader or in doplhin
2.
3.
  
Actual results:
"Error. Out of memory" (I have more than 1 GB RAM free and 8GB of swap)

Expected results:
connected to remote location

Additional info:
in .xsession-erros is:
kio_sftp(12459): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
kio_sftp(12459): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

Comment 1 Michal Hlavinka 2010-04-21 19:59:51 UTC
I've found upstream bug, resolved as DOWNSTREAM:

https://bugs.kde.org/show_bug.cgi?id=234302

can anyone have a look at it?

Comment 2 Rex Dieter 2010-04-21 20:13:14 UTC
Upstream comment,

This has been fixed on Ubuntu see
https://bugs.launchpad.net/ubuntu/+source/libssh/+bug/562240

kdebase (runtime) on Fedora should be rebuilt with the new libssh version.
Please file a bug report there.

Comment 3 Rex Dieter 2010-04-21 20:17:51 UTC
Looks like we'll need to do a bundled libssh-0.4.2/kdebase-runtime update, I'm tagging libssh-0.4.2 for buildroots now.

Comment 4 Rex Dieter 2010-04-21 20:18:40 UTC
must've been some sort of abi borkage?

Comment 5 Michal Hlavinka 2010-04-22 07:42:46 UTC
kdebase-runtime-4.4.2-3.fc13.x86_64 fixes this bug for me, thanks

Comment 6 Fedora Update System 2010-04-23 13:12:40 UTC
kdebase-runtime-4.4.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kdebase-runtime-4.4.2-3.fc13

Comment 7 Fedora Update System 2010-04-23 13:13:16 UTC
kdebase-runtime-4.4.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kdebase-runtime-4.4.2-3.fc12

Comment 8 Fedora Update System 2010-04-23 13:15:02 UTC
kdebase-runtime-4.4.2-3.fc11,libssh-0.4.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdebase-runtime-4.4.2-3.fc11,libssh-0.4.2-1.fc11

Comment 9 Fedora Update System 2010-04-25 14:02:24 UTC
kdebase-runtime-4.4.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdebase-runtime-4.4.2-3.fc13

Comment 10 Fedora Update System 2010-04-27 02:26:50 UTC
kdebase-runtime-4.4.2-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdebase-runtime-4.4.2-3.fc12

Comment 11 Rex Dieter 2010-04-28 15:16:02 UTC
*** Bug 581342 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-04-30 17:11:54 UTC
kdebase-runtime-4.4.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-04-30 17:18:23 UTC
kdebase-runtime-4.4.2-3.fc11, libssh-0.4.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.