Bug 58322 - Kickstart fails when using RAID1 swap devices
Kickstart fails when using RAID1 swap devices
Status: CLOSED DUPLICATE of bug 55310
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 05:47 EST by Jos Vos
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-14 05:49:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file causing the problem. (2.58 KB, text/plain)
2002-01-14 05:48 EST, Jos Vos
no flags Details
Anaconda dump file. (47.79 KB, text/plain)
2002-01-14 05:49 EST, Jos Vos
no flags Details

  None (edit)
Description Jos Vos 2002-01-14 05:47:51 EST
Description of Problem:
When specifying a RAID1 swap device in the kickstart file, Anaconda fails with a
"TypeError: number coercion failed" message (Anaconda dump attached).

How Reproducible:
With attached ks.cfg file.

Additional information:
The same ks.cfg file with only the swap parts non-RAID1 works fine.  Diff output

32,33c32,35
< part raid.71 --size 1050 --ondisk hda
< part raid.72 --size 1050 --ondisk hdb
---
> #part raid.71 --size 1050 --ondisk hda
> #part raid.72 --size 1050 --ondisk hdb
> part swap --size 1050 --ondisk hda
> part swap --size 1050 --ondisk hdb
42c44
< raid swap      --level 1 --device md7 raid.71 raid.72
---
> #raid swap      --level 1 --device md7 raid.71 raid.72
Comment 1 Jos Vos 2002-01-14 05:48:55 EST
Created attachment 42376 [details]
Kickstart file causing the problem.
Comment 2 Jos Vos 2002-01-14 05:49:51 EST
Created attachment 42377 [details]
Anaconda dump file.
Comment 3 Jeremy Katz 2002-01-15 14:06:24 EST

*** This bug has been marked as a duplicate of 55310 ***

Note You need to log in before you can comment on or make changes to this bug.