Bug 5833 - No bootdisk created during upgrade 6.0 to 6.1 results in non-bootable system
No bootdisk created during upgrade 6.0 to 6.1 results in non-bootable system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
http://pobox.com/~e.maryniak/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-11 10:28 EDT by Eric Maryniak
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-11 11:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Maryniak 1999-10-11 10:28:59 EDT
First of all: applaus for 6.1's easy, user-friendly install!
Imho, with some more finetuning and more PnP supported
devices detection a la Win98, and availibility of good
Office Suites like Applixware that can read Word and Excel
files, Linux will definitately conquer the user desktop.

Now the problem: my 6.0 system was dual-boot Win98 and
RedHat 6.0, the switch in a [multi] config.sys with Linux
booted by loadlin.exe. Reason: I have >1024 cylinders and
I cannot use Lilo well.
Now during the "automatic upgrade", the installer does
everything very ok, however it did not give me the
oppurtunity to make a boot disk (with the working kernel),
and just installed lilo in the mbr.
Hence I had a system that I, in principle, could not boot:
fortunately, after fdisk /mbr, and booting the older kernel
from 6.0, it still worked (with lots of boot errors), I got
a prompt and immediately copied the new /boot/vmlinuz-bla
kernel to my C: (/dos/linuximg on /dev/hdax).

I would recommend giving users an option to create a
bootdisk (which can come in handy, anyways) during the
installation... (you may want to give some hints as to
to use loadlin.exe)

(if i've missed this option in the upgrade selection
(clicked Ok too soon), i am terribly sorry)

Kind regards, Eric Maryniak
Comment 1 Jay Turner 1999-10-11 11:39:59 EDT
*** This bug has been marked as a duplicate of 5578 ***

Note You need to log in before you can comment on or make changes to this bug.