Bug 5578 - Bootnet.img does not creat rescue disk
Bootnet.img does not creat rescue disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-05 09:37 EDT by vrossum
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 11:12:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vrossum 1999-10-05 09:37:51 EDT
I used bootnet.img to update from 6.0 to 6.1.
The installer did not make a rescue disk.

This is very annoying when you have a dual boot NT/linux
system and use the NT loader.
(In that case you need the rescue disk for the first
boot...)
Comment 1 Jay Turner 1999-10-11 11:39:59 EDT
*** Bug 5833 has been marked as a duplicate of this bug. ***

First of all: applaus for 6.1's easy, user-friendly install!
Imho, with some more finetuning and more PnP supported
devices detection a la Win98, and availibility of good
Office Suites like Applixware that can read Word and Excel
files, Linux will definitately conquer the user desktop.

Now the problem: my 6.0 system was dual-boot Win98 and
RedHat 6.0, the switch in a [multi] config.sys with Linux
booted by loadlin.exe. Reason: I have >1024 cylinders and
I cannot use Lilo well.
Now during the "automatic upgrade", the installer does
everything very ok, however it did not give me the
oppurtunity to make a boot disk (with the working kernel),
and just installed lilo in the mbr.
Hence I had a system that I, in principle, could not boot:
fortunately, after fdisk /mbr, and booting the older kernel
from 6.0, it still worked (with lots of boot errors), I got
a prompt and immediately copied the new /boot/vmlinuz-bla
kernel to my C: (/dos/linuximg on /dev/hdax).

I would recommend giving users an option to create a
bootdisk (which can come in handy, anyways) during the
installation... (you may want to give some hints as to
to use loadlin.exe)

(if i've missed this option in the upgrade selection
(clicked Ok too soon), i am terribly sorry)

Kind regards, Eric Maryniak
Comment 2 Jay Turner 1999-10-11 11:41:59 EDT
*** Bug 5730 has been marked as a duplicate of this bug. ***

When upgrading from 6.0 to 6.1 in a dual-boot system lilo
was reconfigured with boot=/dev/hda, while originally was
boot=/dev/hda5.

------- Additional Comments From Ville.Sulko@tpo.fi  10/11/99 10:44 -------
In addition, upgrade does not preserve special configurations in
lilo.conf, such as mine 'disk=/dev/sda bios=0x81, disk=/dev/sdb
bios=0x80' [yes, it's stupid not to have the lowest SCSI-ID as the
boot-disk, but this one is like it is for historic reasons]. This
rendered the system unbootable after upgrade.
Fortunately I was able to fix it using just the bootable RH61 CD,
but the fact that the original lilo.conf wasn't even preserved as
lilo.conf.rpmsave made the fix a bit harder, since I didn't remember
the correct syntax for those configuration lines...
Comment 3 Jay Turner 1999-10-20 15:09:59 EDT
This issue has been forwarded to a developer for further action.
Comment 4 Jay Turner 1999-11-02 11:12:59 EST
*** Bug 6626 has been marked as a duplicate of this bug. ***

You *REALLY* to prompt the user before installing LILO
information over an existing LILO configuration.  Why not
look at the MBR to see whether LILO information is already
in place, then prompt the user?

By the way, I REALLY like the new GUI install!  Keep up the
good work.

------- Additional Comments From jturner@redhat.com  11/02/99 11:09 -------


*** This bug has been marked as a duplicate of 5576 ***These issues with lilo config during an upgrade are fixed in the
latest errata images available at support.redhat.com/errata

Note You need to log in before you can comment on or make changes to this bug.