Bug 58354 - man mkfs errors
man mkfs errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
: 59383 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 16:33 EST by Chris Ricker
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 12:50:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-01-14 16:33:04 EST
mkfs(8) man page references several man pages which don't exist:

mkfs.xiafs(8)
mkfs.xfs(8)
mkfs.ext2(8)

mkfs(8) also fails to reference several relevant man pages which do exist:

mkfs.bfs(8)
mkfs.vfat(8)
Comment 1 Elliot Lee 2002-03-08 13:47:44 EST
The references to non-existent man pages will stay, just because they point to
packages that are most likely optional or third party...

I've added the new ones for completeness, though.
Comment 2 Elliot Lee 2002-03-08 13:51:46 EST
*** Bug 59383 has been marked as a duplicate of this bug. ***
Comment 3 Chris Ricker 2002-03-08 14:00:54 EST
mkfs.ext2(8) should instead be mke2fs(8) 

(e2fsprogs installs mkfs.ext2 and mke2fs, but the only relevant man page it
supplies is mke2fs.8, not mkfs.ext2.8)

I'm not sure if the bug there is in e2fsprogs (ie, should it make mkfs.ext2.8 a
symlink to mke2fs.8?; the commands mkfs.ext2 and mke2fs are simply hard links to
the same file) or in util-linux (ie, should it reference mke2fs.8 instead of
mkfs.ext2.8?).  One of the two needs updating, though.

xfs I've not messed with yet, and xiafs I haven't used in so many years I can't
remember how it worked ;-)
Comment 4 Elliot Lee 2002-03-08 14:05:16 EST
I fixed the man page stuff in e2fsprogs-1.26-2, so this isn't an issue.
mkfs.ext2 is the saner thing to use.
Comment 5 Johnray Fuller 2002-04-04 17:53:12 EST
I can't get any of the MAN pages to work in the latest build, so I sam reopening
this bug.

I get this message:

# man mkfs.ext3

<standard input>:2: realpath on `man8/mke2fs.8' failed: No such file or directory
Comment 6 Chris Ricker 2002-04-04 18:10:05 EST
The problem is that mke2fs.8, mkfs.ext2.8, and mkfs.ext3.8 were created as hard
links to the same file, which just self-referentially references mke2fs.8:

[root@station6 man8]# ls -li mkfs.ext2.8.gz mke2fs.8.gz mkfs.ext3.8.gz
1498535 -rw-r--r--    3 root     root           47 Apr  3 11:25 mke2fs.8.gz
1498535 -rw-r--r--    3 root     root           47 Apr  3 11:25 mkfs.ext2.8.gz
1498535 -rw-r--r--    3 root     root           47 Apr  3 11:25 mkfs.ext3.8.gz
[root@station6 man8]# cp mke2fs.8.gz foo.8.gz
[root@station6 man8]# gunzip foo.8.gz
gunzip: foo.8 already exists; do you wish to overwrite (y or n)? y
[root@station6 man8]# cat foo.8 
.so man8/mke2fs.8
[root@station6 man8]# exit

mkfs.ext3 and mke2fs should be hardlinks to a file containing:

.so man8/mkfs.ext2.8

and then mkfs.ext2.8 needs to be a file with the actual content

(or something like that)

Hmm, this needs to be changed to Red Hat Linux Beta and Beta 3 / Beta 4.  Not
sure if I can actually do that, though.
Comment 7 Johnray Fuller 2002-04-04 21:00:54 EST
BTW, to read man pages, use the zcat command.

So, have you checked this out yet, sopwith?
Comment 8 Elliot Lee 2002-04-05 12:50:00 EST
I'm supposed to be on vacation through Monday, so I may not get to fixing it 
until after then.

IIRC mke2fs was the actual man page and mkfs.ext* were supposed to be the 
redirects. Maybe I accidentally included mke2fs in the list of files that I 
created with the one-line redirect thing - if so, it should be a trivial fix 
that you can build yourself if so inclined.
Comment 9 Elliot Lee 2002-04-15 10:53:54 EDT
Appears to be fixed (suboptimally) in e2fsprogs-1.27-3

Note You need to log in before you can comment on or make changes to this bug.