Bug 58369 - [noathlon] kernel-2.4.9 Athlon rpm Panics on reboot on Athlon
[noathlon] kernel-2.4.9 Athlon rpm Panics on reboot on Athlon
Status: CLOSED DUPLICATE of bug 55040
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 06:48 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 08:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-15 06:48:47 EST
Description of Problem:
Upon upgrade from 2.4.7 to Kernel 2.4.9 on a MSI 6378 Board Athlon Celeron 900
System,
the kernel panics on reboot. 
Its a VIA Chipset.

Version-Release number of selected component (if applicable):
2-4-9

How Reproducible:
install on athlon system and boot.

Additional Information:

this also happens on self-compiled original linux kernels from 2.4.9 on to 2.4.17.
It is a known issue of too optimistic athlon optimizations. 

2.4.7 kernel output:
Jan 10 13:51:13 runes kernel:  *** Motherboard with possibly underspec'ed
Jan 10 13:51:13 runes kernel:  *** voltage regulator or broken VIA chipset bios
detected
Jan 10 13:51:13 runes kernel:  *** Athlon optimisations disabled.

The kernel 2.4.7 complained on boot about overoptimistic VIA Chipset settings or
underspec voltage regulator and disabled athlon optimizations.

Therefore I tried building / Installing i686 kernels instead of athlon kernels.

This works stable. The system now runs a i686 compiled 2.4.17 for a while
without incident.


Suggest: If detecting VIA chipset with these issues, do not install athlon
optimized kernels
Comment 1 Arjan van de Ven 2002-01-15 08:02:27 EST
Even better idea: recently the cause was found and it turns out that some bioses
leave the chipset in debugging mode. Our next kernel will turn off that
debugging mode and all will be well. In the mean time, passing "noathlon" on the
kernel commandline will disable athlon code as well...
Comment 2 Arjan van de Ven 2002-01-18 13:40:10 EST

*** This bug has been marked as a duplicate of 55040 ***

Note You need to log in before you can comment on or make changes to this bug.