Bug 583790 - remove .desktop entry in applications > system tools
remove .desktop entry in applications > system tools
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: f13artwork 588537
  Show dependency treegraph
 
Reported: 2010-04-19 14:04 EDT by Máirín Duffy
Modified: 2015-03-03 17:47 EST (History)
4 users (show)

See Also:
Fixed In Version: nautilus-2.30.1-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 588537 (view as bug list)
Environment:
Last Closed: 2010-05-05 03:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2010-04-19 14:04:03 EDT
Description of problem:

Hi, since Nautilus is accessible already in the (relatively new) 'Places' menu, it's a little redundant to have a 'File Manager' entry in Applications > System Tools. The GNOME design team brought this up as an issue in Fedora that we should address so I'd like to request the .desktop file be removed. If we can keep our default menus lean then I think they'll be easier to navigate through.

Thanks,
~m
Comment 1 Adam Williamson 2010-04-30 15:13:09 EDT
This bug was discussed at the 2010/04/30 blocker review meeting. 

It is accepted as a direct blocker as it hits the criterion "No application may unintentionally appear twice in the menus. In particular, things under System must not appear under Applications" - https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria . 

Please try as hard as possible to have the changes ready for Tuesday 2010/05/04, when the Fedora 13 RC stage will be starting up. Thank you.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Máirín Duffy 2010-04-30 15:33:01 EDT
it looks like the bug name has been changed though.

this isn't a case of the same application appearing twice. it's a case of the same icon appearing twice. nautilus and the cd/dvd burner app to the user are two separate apps. simply removing the .desktop entry i think is going to cause problems. how are folks then going to be able to burn cds?
Comment 3 Máirín Duffy 2010-05-03 17:43:08 EDT
whoops sorry I confused this with another bug, please disregard comment 2.
Comment 4 Fedora Update System 2010-05-04 06:49:42 EDT
nautilus-2.30.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nautilus-2.30.1-3.fc13
Comment 5 Fedora Update System 2010-05-04 19:53:28 EDT
nautilus-2.30.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nautilus-2.30.1-3.fc13
Comment 6 Adam Williamson 2010-05-04 20:37:25 EDT
as per bodhi comment, looks good to me.
Comment 7 Fedora Update System 2010-05-05 03:18:16 EDT
nautilus-2.30.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Gene Snider 2010-05-05 14:49:15 EDT
OK, I see the reasoning, but now I can't right click "Home Folder" and add a launcher to gnome-panel.  I enabled File Browser in Other and added that launcher to gnome-panel.  Is there another work around for when File Browser is removed from the Other menu?

Gene
Comment 9 Máirín Duffy 2010-05-05 14:55:12 EDT
Hi Gene,

Why would you add a panel launcher to launch nautilus when the panel already has the places menu built-in?
Comment 10 Máirín Duffy 2010-05-05 14:56:18 EDT
(Also note that you may always add a launcher for any application whether it's in the menus or not via the very first item in the 'add to panel...' dialog: 'custom application launcher')
Comment 11 Gene Snider 2010-05-05 15:14:51 EDT
Hi Martin,

I have a personal preference for the simple Main Menu icon and a separate icon for File Manager.  I forgot about Custom Application Launcher, thanks for the reminder.

Gene
Comment 12 Máirín Duffy 2010-05-05 15:26:15 EDT
Hi Gene, 

Sure I'm glad the suggestion worked for you!

~Máirín

Note You need to log in before you can comment on or make changes to this bug.