Bug 58381 - Several man pages missing
Summary: Several man pages missing
Status: CLOSED DUPLICATE of bug 147076
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-15 15:20 UTC by Harri Haataja
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 19:32:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Man pages for files in /etc/sysconfig (9.72 KB, text/plain)
2003-12-01 20:02 UTC, F. William Lynch
no flags Details

Description Harri Haataja 2002-01-15 15:20:12 UTC
Description of Problem:
Man pages for files like static-routes and other sysconfig files are missing.
All configuration files should be explained somewhere in a normal place.
Man pages are the normal place and this is one of the reasons "Linux" and RHL in
particular are ridiculed. (Mostly by the proud BSD people =)

Version-Release number of selected component (if applicable):
All?

How Reproducible:
100% =)

Steps to Reproduce:
1. man -k static-routes
2. man networks
3. 

Actual Results:
static-routes: nothing appropriate
No manual entry for networks


Expected Results:
Informative manuals for vital configuration files.

Additional Information:
Having gui tools that no-one uses is not an excuse. =)
I can figure these out by reading the scripts but I view this as a flaw anyway.

Comment 1 Trond Eivind Glomsrxd 2002-01-15 17:05:06 UTC
These files are documented in the initscripts doc directory, there are no man pages.

Comment 2 Scott R. Godin 2003-05-01 21:22:01 UTC
confirming this as *still missing in RH 8.0*

Comment 3 F. William Lynch 2003-12-01 20:02:35 UTC
Created attachment 96263 [details]
Man pages for files in /etc/sysconfig

Comment 4 Bill Nottingham 2003-12-01 20:05:33 UTC
Sorry about not responding earlier to the mail...

One thing that could be useful here is to generate docs as xml and
then genreate man pages from that. Not sure how much extra work that
would be, but it would then allow autogeneration of both manpages and
the sysconfig.txt meta document.

Comment 5 Bill Nottingham 2005-09-29 19:32:17 UTC

*** This bug has been marked as a duplicate of 14076 ***

Comment 6 Bill Nottingham 2005-09-29 19:32:35 UTC

*** This bug has been marked as a duplicate of 147076 ***


Note You need to log in before you can comment on or make changes to this bug.