Bug 14076 - Testing Voodoo3 config during install locks the machine
Testing Voodoo3 config during install locks the machine
Status: CLOSED DUPLICATE of bug 14474
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-16 14:58 EDT by mchampig
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 16:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mchampig 2000-07-16 14:58:18 EDT
Could have been filed under anaconda I suppose. During Xconfiguration screen my Voodoo3
is detected properly, but warns that it cannot probe for RAM. I click on 16M RAM and then
clicked on "Test this configuration". The test screen came up (albiet with a massive viewport).
I found the countdown test message box and clicked "Yes". I was brought back to the
Xconfigurator screen. At that point the machine locked hard. I could not get to the other
consoles to give more details, and had to reboot.

Workaround is possibly to configure card later after selecting a text login.
Comment 1 mchampig 2000-07-16 17:36:59 EDT
Update:

I left the RAM unprobed and tested the configuration. This time I got a 640x480 screen and it returned to the Xconfigurator
screen. I went forward into the custom configuration screen and was offered a single choice...640x480 at 8-bit depth!!!!
I *thought* my Voodoo3 was more capable. :-) The console shows it recognized texture memory of 15.97M. (Weird number).

Anyway, during the install screen the graphics are totally scrambled. The progress meter widgets are visible but are superimposed
with the Red Hat logo pixmap. The button widgets have disappeared too!

I think Voodoo3 configuration needs *lots* of work.

Comment 2 Trond Eivind Glomsrxd 2000-07-17 10:45:12 EDT
anaconda doesn't use Xconfigurator in GUI mode... please file a separate bug on
that. What did you mean by "left the RAM unproped" - did you just leave it at
256 kB? If so, that explains the 640x480 (and the texture memory is probably
card memory - memory used for screen memory)
Comment 3 mchampig 2000-07-17 11:43:30 EDT
Yes, that's correct. I left it checked at 256k so I suppose that explains the
small window (though
it doesn't explain the scrambed graphics during the install afterwards). 

Ultimately, it should probe correctly for 16MB and not lock when coming back
from the test
screen.
Comment 4 mchampig 2000-07-18 14:03:49 EDT
Just to clarify...the problem is with anaconda. It is making very poor choices
about default
screen resolutions. I've verified this now with Voodoo3, S3/Virge, and Matrox
Mystique
cards. It usually gives either an interlaced screen mode or a huge viewport.
Pressing the
"Test Configuration" button is *very* risky. Note that I've hung a lot of
installs that way
or else the graphics are "frozen" but the install proceeds (I can tell by
looking at the other
consoles).

All cards are very nicely configured by Xconfigurator once I've completed the
install. So it's
just a matter of selecting a text login the first time, configuring the cards,
and starting at
runlevel 7 for the next reboot.


Comment 5 Michael Fulbright 2000-07-27 14:48:18 EDT
Please verify against beta 5 - we seem to have corrected this problem.
Comment 6 Michael Fulbright 2000-08-17 16:34:45 EDT

*** This bug has been marked as a duplicate of 14474 ***
Comment 7 Bill Nottingham 2005-09-29 15:32:25 EDT
*** Bug 58381 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.