Bug 583976 - ping6 does not support -F flowlabel option
ping6 does not support -F flowlabel option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-20 08:42 EDT by Peter Bieringer
Modified: 2014-11-09 17:32 EST (History)
3 users (show)

See Also:
Fixed In Version: iputils-20071127-11.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586114 (view as bug list)
Environment:
Last Closed: 2010-05-28 13:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2010-04-20 08:42:00 EDT
Description of problem:
ping6 does not support -F flowlabel option

Version-Release number of selected component (if applicable):
# rpm -qf `which ping6` 
iputils-20071127-10.fc12.i686

How reproducible:
always

Steps to Reproduce:

# ping6 -c 1000 -f ::1 -F 12345

 
Actual results:

Flow labels are not supported.
(no ping)

Expected results:

Supported Flow Labels

Additional info:

Kernel 2.6.32.9-70.fc12.i686

# ping6 -c 1000 -f ::1 
PING ::1(::1) 56 data bytes
 
--- ::1 ping statistics ---
1000 packets transmitted, 1000 received, 0% packet loss, time 45ms
rtt min/avg/max/mdev = 0.007/0.019/5.680/0.193 ms, ipg/ewma 0.045/0.008 ms
Comment 1 Peter Bieringer 2010-04-22 13:21:59 EDT
Perhaps related: https://bugzilla.redhat.com/show_bug.cgi?id=583985
Comment 2 Jiri Skala 2010-04-23 10:03:51 EDT
This isn't related to traceroute issue.

The flowlabel functionality is disabled by default therefore "Flow labels are not supported" message is printed.

Simple enabling doesn't fix it due to problems with headers. I have to investigate it a bit.
Comment 3 Peter Bieringer 2010-04-24 06:45:11 EDT
During investigation, would be nice if you can also look into the next hop option (source routing), which is not working for IPv6 at all: 

# ping6 -c 1 2001:xxxx:xxxx:65::1 2001:xxxx:xxxx:66:5054:ff:fexx:xxxx
PING ipv6-client-b(ipv6-client-b) 56 data bytes
ping: sendmsg: Invalid argument


IPv4 works (after enabling accept IPv4 source routing on all participating nodes):
# ping 10.0.65.1 ipv4-client-b
PING ipv4-client-b (10.0.66.2) 56(124) bytes of data.
64 bytes from ipv4-client-b (10.0.66.2): icmp_seq=1 ttl=63 time=2.78 ms
LSRR: 	ipv4-router-c-65 (10.0.65.1)
Comment 4 Jiri Skala 2010-04-28 04:32:08 EDT
Disabling flowlabel functinality seems to be an intention. Well, I've add glibc owner to ask him about following issue:

Ipuitls use glibc-headers but the flowlabel needs in6_flowlabel-req structure defined in linux/in6.h (kernel headers). This header conflicts with glibs's headers. I wouldn't like to separate missing structure to proprietary header.

Questions toward glibc: Is there some planning to add flowlabel to glibc's headers?

Thanks

Jiri
Comment 5 Fedora Update System 2010-05-11 10:06:28 EDT
iputils-20071127-11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/iputils-20071127-11.fc12
Comment 6 Fedora Update System 2010-05-12 13:58:08 EDT
iputils-20071127-11.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iputils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/iputils-20071127-11.fc12
Comment 7 Peter Bieringer 2010-05-13 10:58:04 EDT
Option -F is now working, but value on -F is interpreted as hexadecimal, I don't know whether this is proper or not, but sure not mentioned on the man page:

# ping6 -c 1 -F 18 ::1
PING ::1(::1) , flow 0x00018, 56 data bytes
64 bytes from ::1: icmp_seq=1 ttl=64 time=0.027 ms

--- ::1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.027/0.027/0.027/0.000 ms


-F 18 results in flow 0x00018 which was also then seen on tcpdump
Comment 8 Peter Bieringer 2010-05-13 11:00:25 EDT
Just note that "next hop" option is still not working, should I file a new bug or extend subject of this one?
Comment 9 Fedora Update System 2010-05-28 13:56:51 EDT
iputils-20071127-11.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.