Bug 586114 - ping6 does not support -F flowlabel and nexthop option
ping6 does not support -F flowlabel and nexthop option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iputils (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Skala
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:11 EDT by Peter Bieringer
Modified: 2014-11-09 17:32 EST (History)
6 users (show)

See Also:
Fixed In Version: iputils-20071127-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 583976
Environment:
Last Closed: 2010-11-10 15:41:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2010-04-26 16:11:05 EDT
Final RHEL6 should be also have fixed this issue because of:

http://www.redhat.com/rhel/beta/
Next generation networking: comprehensive IPv6 support

# rpm -qf `which ping6` 
iputils-20071127-9.1.el6.i686

# ping6 -c 1000 -f ::1 -F 12345
Flow labels are not supported.

 LC_ALL=C ping6 -c 1 ::1 ::1
PING ::1(::1) 56 data bytes
ping: sendmsg: Invalid argument


+++ This bug was initially created as a clone of Bug #583976 +++

Description of problem:
ping6 does not support -F flowlabel option

Version-Release number of selected component (if applicable):
# rpm -qf `which ping6` 
iputils-20071127-10.fc12.i686

How reproducible:
always

Steps to Reproduce:

# ping6 -c 1000 -f ::1 -F 12345

 
Actual results:

Flow labels are not supported.
(no ping)

Expected results:

Supported Flow Labels

Additional info:

Kernel 2.6.32.9-70.fc12.i686

# ping6 -c 1000 -f ::1 
PING ::1(::1) 56 data bytes
 
--- ::1 ping statistics ---
1000 packets transmitted, 1000 received, 0% packet loss, time 45ms
rtt min/avg/max/mdev = 0.007/0.019/5.680/0.193 ms, ipg/ewma 0.045/0.008 ms

--- Additional comment from pb@bieringer.de on 2010-04-22 13:21:59 EDT ---

Perhaps related: https://bugzilla.redhat.com/show_bug.cgi?id=583985

--- Additional comment from jskala@redhat.com on 2010-04-23 10:03:51 EDT ---

This isn't related to traceroute issue.

The flowlabel functionality is disabled by default therefore "Flow labels are not supported" message is printed.

Simple enabling doesn't fix it due to problems with headers. I have to investigate it a bit.

--- Additional comment from pb@bieringer.de on 2010-04-24 06:45:11 EDT ---

During investigation, would be nice if you can also look into the next hop option (source routing), which is not working for IPv6 at all: 

# ping6 -c 1 2001:xxxx:xxxx:65::1 2001:xxxx:xxxx:66:5054:ff:fexx:xxxx
PING ipv6-client-b(ipv6-client-b) 56 data bytes
ping: sendmsg: Invalid argument


IPv4 works (after enabling accept IPv4 source routing on all participating nodes):
# ping 10.0.65.1 ipv4-client-b
PING ipv4-client-b (10.0.66.2) 56(124) bytes of data.
64 bytes from ipv4-client-b (10.0.66.2): icmp_seq=1 ttl=63 time=2.78 ms
LSRR: 	ipv4-router-c-65 (10.0.65.1)
Comment 2 RHEL Product and Program Management 2010-04-26 17:27:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jiri Skala 2010-04-29 16:08:44 EDT
Flowlabel functionality is disabled using ifdef. This state is probably intentionally because there is no definition of flowlabel structure in glibc. Kernel headers containing necessary definition conflicts with glib.
I've asked glibc package owner about future support of flowlabel structure in the original bug (#583976). Currently no answer.

I've sent an inquiry to upstream if disabling flowlabel relates to kernel/glibc headers conflicting.

I prefer enabling flowlabel if there is sufficient support in glibc.
Comment 7 Martin Cermak 2010-09-17 02:10:28 EDT
=> VERIFIED
Comment 8 releng-rhel@redhat.com 2010-11-10 15:41:22 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.