Bug 584244 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 546155
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:71c42dbc7ea3b591e7031476ea2...
Keywords:
: 587121 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 05:43 UTC by Kerry
Modified: 2010-05-28 12:56 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-28 12:56:11 UTC


Attachments (Terms of Use)
File: backtrace (84.58 KB, text/plain)
2010-04-21 05:43 UTC, Kerry
no flags Details
File: comment (5.46 KB, text/plain)
2010-04-21 05:43 UTC, Kerry
no flags Details

Description Kerry 2010-04-21 05:43:03 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
Attached file: comment
component: firefox
executable: /usr/lib/firefox-3.5/firefox
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Clicked a link in Blackboard (http://muso.monash.edu.au/webct)
2.
3.

Comment 1 Kerry 2010-04-21 05:43:07 UTC
Created attachment 407987 [details]
File: backtrace

Comment 2 Kerry 2010-04-21 05:43:09 UTC
Created attachment 407988 [details]
File: comment

Comment 3 Kerry 2010-04-21 05:51:20 UTC
I also filed bug 584204 from an earlier crash in the same website. I assume it is related in some way to the crashes.

Comment 4 Karel Klíč 2010-05-25 08:52:06 UTC
*** Bug 587121 has been marked as a duplicate of this bug. ***

Comment 5 Chris Campbell 2010-05-28 12:53:57 UTC
#7  0x0087b316 in IA__g_logv (log_domain=0x8c7366 "GLib", 
    log_level=<value optimized out>, format=
    0x8ce93c "%s: failed to allocate %u bytes", args1=
    0xbfa252cc "\354\353\214") at gmessages.c:549
        depth = 1
        domain = <value optimized out>
        data = <value optimized out>
        log_func = <value optimized out>
        domain_fatal_mask = 5
        masquerade_fatal = <value optimized out>
        test_level = <value optimized out>
        was_recursion = 0
        i = <value optimized out>
#8  0x0087b347 in IA__g_log (log_domain=0x8c7366 "GLib", log_level=
    G_LOG_LEVEL_ERROR, format=0x8ce93c "%s: failed to allocate %u bytes")
    at gmessages.c:569
        args = <value optimized out>
#9  0x0087958f in IA__g_malloc (n_bytes=8) at gmem.c:135
        mem = <value optimized out>
#10 0x0088f8c7 in IA__g_slice_alloc (mem_size=8) at gslice.c:824
        chunk_size = 8
        mem = <value optimized out>
#11 0x00890c23 in IA__g_slist_prepend (list=0x83b89820 = {...}, data=
    0x88c9d970) at gslist.c:160
        new_list = 0x0
#12 0x00933d1b in g_object_init (object=Traceback (most recent call last):
  File "/usr/share/glib-2.0/gdb/gobject.py", line 72, in to_string
    name = g_type_name_from_instance (self.val)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 59, in g_type_name_from_instance
    name = g_type_to_name (gtype)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 24, in g_type_to_name
    typenode = lookup_fundamental_type (typenode)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 17, in lookup_fundamental_type
    return val[typenode >> 2].address()
TypeError: 'gdb.Value' object is not callable
, class=0xb751ede0) at gobject.c:720
No locals.
#13 0x0094f470 in IA__g_type_create_instance (type=3048659168) at gtype.c:1666
        pnode = <value optimized out>
        node = 0xb5b6d8e0
        instance = Traceback (most recent call last):
  File "/usr/share/glib-2.0/gdb/gobject.py", line 72, in to_string
    name = g_type_name_from_instance (self.val)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 59, in g_type_name_from_instance
    name = g_type_to_name (gtype)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 24, in g_type_to_name
    typenode = lookup_fundamental_type (typenode)
  File "/usr/share/glib-2.0/gdb/gobject.py", line 17, in lookup_fundamental_type
    return val[typenode >> 2].address()
TypeError: 'gdb.Value' object is not callable

        class = 0xb751ede0
        i = 3
        total_size = <value optimized out>
#14 0x00933e69 in g_object_constructor (type=3048659168, 
    n_construct_properties=0, construct_params=0x0) at gobject.c:1383
        object = <value optimized out>
#15 0x00934e38 in IA__g_object_newv (object_type=3048659168, n_parameters=0, 
    parameters=0x0) at gobject.c:1171
        cparams = 0x0
        oparams = 0x0
        nqueue = 0x0
        object = <value optimized out>
        class = 0xb751ede0
        unref_class = 0x0
        slist = 0x0
        n_total_cparams = <value optimized out>
        n_cparams = 0
        n_oparams = 0
        n_cvalues = <value optimized out>
        cvalues = <value optimized out>
        clist = 0x0
        newly_constructed = <value optimized out>
        i = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_object_newv"
#16 0x00935cba in IA__g_object_new_valist (object_type=3048659168, 
    first_property_name=0x0, var_args=0xbfa256d8 ";\353\224")
    at gobject.c:1323
        class = <value optimized out>
        params = <value optimized out>
        name = <value optimized out>
        object = 0x0
        n_params = 0
        n_alloced_params = 16
        __PRETTY_FUNCTION__ = "IA__g_object_new_valist"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Chris Campbell 2010-05-28 12:56:11 UTC
Thank you for taking the time to make this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 546155 ***


Note You need to log in before you can comment on or make changes to this bug.