Bug 584354 - [abrt] crash in SwPostItMgr::CorrectPositions
Summary: [abrt] crash in SwPostItMgr::CorrectPositions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7d733d15d7b11d442eae3a63d2b...
: 584375 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 13:28 UTC by Pavel Alexeev
Modified: 2010-06-02 18:09 UTC (History)
1 user (show)

Fixed In Version: openoffice.org-3.2.0-12.23.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 18:09:42 UTC


Attachments (Terms of Use)
File: backtrace (61.02 KB, text/plain)
2010-04-21 13:28 UTC, Pavel Alexeev
no flags Details
Document on which crash occurred (64.00 KB, application/msword)
2010-04-21 21:02 UTC, Pavel Alexeev
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 93818 None None None Never

Description Pavel Alexeev 2010-04-21 13:28:06 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///tmp/%D0%A2%D0%97%20%D0%B8%D0%BD%D1%82%D0%B5%D0%B3%D1%80%D0%B0%D1%86%D0%B8%D0%B8%20SugarCRM%20%D0%B8%201%D0%A1(vedisoft)%20(2).doc
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
global_uuid: 7d733d15d7b11d442eae3a63d2b82fcba2f36fb1
kernel: 2.6.33.1-24.fc13.i686
package: openoffice.org-writer-1:3.2.0-12.14.fc13
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
Just long time opens.
It does NOT reproduced again.

Comment 1 Pavel Alexeev 2010-04-21 13:28:08 UTC
Created attachment 408064 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-04-21 13:36:51 UTC
This looks like a crash in drawing a postit. Did it happen with a specific document ?, even if that document doesn't crash again for you, could you attach it here ?

Comment 3 Caolan McNamara 2010-04-21 13:43:57 UTC
*** Bug 584375 has been marked as a duplicate of this bug. ***

Comment 4 Pavel Alexeev 2010-04-21 21:01:47 UTC
It also happened again on it document... But I still can't 100% reproduce it...

Document follow.

Comment 5 Pavel Alexeev 2010-04-21 21:02:58 UTC
Created attachment 408183 [details]
Document on which crash occurred

Comment 6 Caolan McNamara 2010-04-22 13:27:14 UTC
I've had no success so far in reproducing this.

Comment 7 Caolan McNamara 2010-04-28 13:50:14 UTC
This might be related to a nasty bug I found in postits. Maybe not, because the document does not have use printer metrics set, but maybe. If it is then this will be fixed with >= openoffice.org-3.2.0-12.18.fc13

I'm not massively hopeful, but I can't reproduce it to be certain, lets assume the best for now.

Comment 8 Fedora Update System 2010-05-22 07:21:50 UTC
openoffice.org-3.2.0-12.23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.23.fc13

Comment 9 Fedora Update System 2010-05-24 19:43:54 UTC
openoffice.org-3.2.0-12.23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.23.fc13

Comment 10 Fedora Update System 2010-06-02 18:09:10 UTC
openoffice.org-3.2.0-12.23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.