Bug 584487 - SELinux is preventing /sbin/consoletype "read" access on /proc/<pid>/cmdline.
SELinux is preventing /sbin/consoletype "read" access on /proc/<pid>/cmdline.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f31dd46f058...
:
: 584488 584624 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 13:06 EDT by Leonardo
Modified: 2010-04-22 07:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 13:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonardo 2010-04-21 13:06:43 EDT
Sumário:

SELinux is preventing /sbin/consoletype "read" access on /proc//cmdline.

Descrição detalhada:

[consoletype tem um tipo permissivo (consoletype_t). Esse acesso não foi
negado.]

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Permitindo acesso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Informações adicionais:

Contexto de origem            system_u:system_r:consoletype_t:s0-s0:c0.c1023
Contexto de destino           unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Objetos de destino            /proc/<pid>/cmdline [ file ]
Origem                        consoletype
Caminho da origem             /sbin/consoletype
Porta                         <Desconhecido>
Máquina                      (removed)
Pacotes RPM de origem         initscripts-9.02-1
Pacotes RPM de destino        
RPM da política              selinux-policy-3.6.32-41.fc12
Selinux habilitado            True
Tipo de política             targeted
MLS habilitado                True
Modo reforçado               Enforcing
Nome do plugin                catchall
Nome da máquina              (removed)
Plataforma                    Linux (removed) 2.6.31.5-127.fc12.i686 #1 SMP Sat
                              Nov 7 21:41:45 EST 2009 i686 athlon
Contador de alertas           2
Visto pela primeira vez em    Qua 21 Abr 2010 14:02:50 BRT
Visto pela última vez em     Qua 21 Abr 2010 14:02:50 BRT
ID local                      c50980a1-254e-435f-8b23-680ca97b15c8
Números de linha             

Mensagens de auditoria não p 

node=(removed) type=AVC msg=audit(1271869370.898:21544): avc:  denied  { read } for  pid=3678 comm="consoletype" path="/proc/2879/cmdline" dev=proc ino=366863 scontext=system_u:system_r:consoletype_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=file

node=(removed) type=SYSCALL msg=audit(1271869370.898:21544): arch=40000003 syscall=11 success=yes exit=0 a0=944cc70 a1=9449028 a2=9448f30 a3=9449028 items=0 ppid=3677 pid=3678 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="consoletype" exe="/sbin/consoletype" subj=system_u:system_r:consoletype_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,consoletype,consoletype_t,unconfined_t,file,read
audit2allow suggests:

#============= consoletype_t ==============
allow consoletype_t unconfined_t:file read;
Comment 1 Daniel Walsh 2010-04-21 13:16:07 EDT
yum -y update
Comment 2 Daniel Walsh 2010-04-21 13:16:32 EDT
*** Bug 584488 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2010-04-22 07:08:17 EDT
*** Bug 584624 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.