Bug 584624 - SELinux is preventing /sbin/consoletype "read" access on /proc/<pid>/cmdline.
SELinux is preventing /sbin/consoletype "read" access on /proc/<pid>/cmdline.
Status: CLOSED DUPLICATE of bug 584487
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:0d74c313a69...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 00:50 EDT by arslan.rozyyev
Modified: 2010-05-16 12:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 07:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arslan.rozyyev 2010-04-22 00:50:15 EDT
Summary:

SELinux is preventing /sbin/consoletype "read" access on /proc//cmdline.

Detailed Description:

[consoletype has a permissive type (consoletype_t). This access was not denied.]

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:consoletype_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                /proc/<pid>/cmdline [ file ]
Source                        consoletype
Source Path                   /sbin/consoletype
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           initscripts-9.02-1
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686 #1 SMP Sat
                              Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   4
First Seen                    Thu 22 Apr 2010 05:39:45 AM TMT
Last Seen                     Thu 22 Apr 2010 05:39:46 AM TMT
Local ID                      f50c4a8b-972c-4457-8c1a-1beb61dd7165
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271896786.468:25795): avc:  denied  { read } for  pid=19266 comm="consoletype" path="/proc/18664/cmdline" dev=proc ino=2624814 scontext=system_u:system_r:consoletype_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=file

node=(removed) type=SYSCALL msg=audit(1271896786.468:25795): arch=40000003 syscall=11 success=yes exit=0 a0=904ec70 a1=904b028 a2=904af30 a3=904b028 items=0 ppid=19265 pid=19266 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="consoletype" exe="/sbin/consoletype" subj=system_u:system_r:consoletype_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,consoletype,consoletype_t,unconfined_t,file,read
audit2allow suggests:

#============= consoletype_t ==============
allow consoletype_t unconfined_t:file read;
Comment 1 Miroslav Grepl 2010-04-22 07:08:17 EDT

*** This bug has been marked as a duplicate of bug 584487 ***

Note You need to log in before you can comment on or make changes to this bug.