Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 584492 - [abrt] crash in hplip-gui-3.10.2-4.fc12 in QPainter::setClipRect () in ~QMultiInputContext
[abrt] crash in hplip-gui-3.10.2-4.fc12 in QPainter::setClipRect () in ~QMult...
Status: CLOSED DUPLICATE of bug 583951
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:68235537f3e233a49c1cf0d084f...
:
: 584045 584818 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 13:25 EDT by ewc
Modified: 2010-04-24 07:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-24 07:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.21 KB, text/plain)
2010-04-21 13:25 EDT, ewc
no flags Details

  None (edit)
Description ewc 2010-04-21 13:25:45 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: python /usr/bin/hp-toolbox
component: hplip
executable: /usr/bin/python
kernel: 2.6.32.11-99.fc12.i686
package: hplip-gui-3.10.2-4.fc12
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 ewc 2010-04-21 13:25:47 EDT
Created attachment 408130 [details]
File: backtrace
Comment 2 Jiri Popelka 2010-04-22 04:24:38 EDT
What is the output of running the following command?
  rpm -qa hplip-gui PyQt4 "qt*"
Comment 3 ewc 2010-04-22 08:21:51 EDT
Here is what I get for my desktop (computer that bug was reported from):

--snip--
[rick@localhost ~]$ rpm -qa hplip-gui PyQt4 "qt*"
qt3-3.3.8b-28.fc12.i686
qt3-designer-3.3.8b-28.fc12.i686
qtiplot-0.9.7.13-1.fc12.i686
qt-devel-4.6.2-8.fc12.i686
qt-sqlite-4.6.2-8.fc12.i686
qt3-devel-3.3.8b-28.fc12.i686
qtparted-0.4.5-22.fc12.i686
qtscriptbindings-0.1.0-10.fc12.i686
PyQt4-4.7.2-2.fc12.i686
qt-mysql-4.6.2-8.fc12.i686
qt-4.6.2-8.fc12.i686
hplip-gui-3.10.2-4.fc12.i686
qt-x11-4.6.2-8.fc12.i686
[rick@localhost ~]$ 
--snip--

I also get a similar bug report from my laptop, but have not reported it from that machine. I will do so after doing this message. However, in case bug is flagged as duplicate and does not allow comments, this is what I get from the laptop:

--snip--
[rick@localhost ~]$ rpm -qa hplip-gui PyQt4 "qt*"
qt3-3.3.8b-28.fc12.i686
qt-sqlite-4.6.2-8.fc12.i686
hplip-gui-3.10.2-4.fc12.i686
PyQt4-4.7.2-2.fc12.i686
qtparted-0.4.5-22.fc12.i686
qt-x11-4.6.2-8.fc12.i686
qt-4.6.2-8.fc12.i686
qtiplot-0.9.7.13-1.fc12.i686
[rick@localhost ~]$
--snip--

I should have noted that I appear to get this abrt notice every time I use either computer. HP device manager usually comes up fine, and even when there are no print jobs, abrt notice appears. HP device manager and printing otherwise appear to function okay.

Background FYI if it helps, both systems were upgraded from f10 to f12 using pre-upgrade and required use of yum to install some apparently missing python stuff for various other gui's to run.
Comment 4 Jiri Popelka 2010-04-22 10:22:15 EDT
*** Bug 584818 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Popelka 2010-04-23 02:32:44 EDT
*** Bug 584045 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2010-04-23 17:28:41 EDT
Please run this command from a terminal window:

su -c 'yum --enablerepo=updates-testing update sip PyQt4'

Do you still see the problem after that?
Comment 7 ewc 2010-04-24 02:04:33 EDT
That appears to have fixed the problem at reboot on both the desktop machine and laptop (4 reboots each machine to test), and it appears to have fixed the abrt notification when shutting down the HP Device Manager on the desktop machine.

On the laptop, clicking on the print setting tab in the HP Device Manager causes the manager to crash with an abrt notification. That may or may not be a different issue (and I am writing this from the desktop), so I will do a separate bug report for that.

Many thanks Tim.
Comment 8 Tim Waugh 2010-04-24 07:00:02 EDT

*** This bug has been marked as a duplicate of bug 583951 ***

Note You need to log in before you can comment on or make changes to this bug.