Bug 58450 - install auto partitioning starts on block 1 - needs to start on block 2
install auto partitioning starts on block 1 - needs to start on block 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Petit-Bianco
Brock Organ
:
: 58499 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-16 18:13 EST by john.goshdigian
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-18 16:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.goshdigian 2002-01-16 18:13:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:
When using the installer to automatically partition a disk device for installation,
it sets up the first partition starting on block 1. 
This results in the following error message after the user completing the installation:
error bootcode overlaps with partition #1. If you really want this, use f1

Suggested Fix: always start first partition at block #2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select "Have installer automatically partition for you"
2.  Note the partition layout (particularly) that partition 1 starts at block 1
3. If you want, do a full installation and witness the error at the end:
	"error bootcode overlaps with partition #1. If you really want this, use f1"
4. Try to boot that disk - Failure

Workaround - use fdisk, but even doing an fdisk and manually settinp up partitions properly, 
one has to reboot the system and start the installation all over again.

Actual Results:  Failed to reboot from the disk that the 7.2 beta1 kit was installed on.

Expected Results:  7.2 beta system to boot up from the installed system disk

Additional info:
Comment 1 Jay Turner 2002-02-13 16:13:00 EST
*** Bug 58499 has been marked as a duplicate of this bug. ***
Comment 2 Phil Copeland 2002-02-14 15:19:57 EST
*nod*
This was an aftereffect of trying to support both AlphaBIOS and SRM
AlphaBIOS allowed the disk to be read using the MSDOS partition scheme and
relied on looking like a normal disk so it was correct in the MSDOS format to
start off at track 1 as the bootloader was encapsulated in the partiton

With SRM, we use the track 2 because the boot loader is not held in the
partition and in fact lurcks on the very first portion of the disk hence the
'wasted' track.

The problem with autopartitioning was that it always read the disk label to
determin if it was a MSDOS format or a BSD format install and formatted
accordingly. I believe the default for no label was MSDOS

As we're supporting SRM only (afaik) the default should be to use track 2 or on
detecting an MSDOS label to throw up a  message something similar to 'MSDOS
Label detected, would you like to proceed in MSDOS style partitioning or use BSD
style for SRM' To keep the legacey people happy.

Phil
=--=
Comment 3 Alexandre Petit-Bianco 2002-02-18 16:12:31 EST
This has been fixed. It triggers a new problem, see <A 
HREF="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=60004">60004</A>.
Comment 4 Jay Turner 2002-03-07 10:38:57 EST
Closing this out since it has been confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.