Bug 584570 - SELinux is preventing /usr/bin/consolehelper-gtk "search" access on gdm.
Summary: SELinux is preventing /usr/bin/consolehelper-gtk "search" access on gdm.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3e9c9fbbf76...
: 584571 584573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 21:06 UTC by Carl G.
Modified: 2010-04-28 03:07 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-28 03:07:27 UTC
Type: ---


Attachments (Terms of Use)

Description Carl G. 2010-04-21 21:06:16 UTC
Summary:

SELinux is preventing /usr/bin/consolehelper-gtk "search" access on gdm.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by consolehelper-g. It is not expected that this
access is required by consolehelper-g and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                staff_u:staff_r:staff_consolehelper_t:s0
Target Context                system_u:object_r:xdm_var_run_t:s0
Target Objects                gdm [ dir ]
Source                        consolehelper-g
Source Path                   /usr/bin/consolehelper-gtk
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           usermode-gtk-1.104.2-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-2.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.2-57.fc13.x86_64
                              #1 SMP Tue Apr 20 08:57:50 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Wed 21 Apr 2010 04:47:54 PM EDT
Last Seen                     Wed 21 Apr 2010 04:47:54 PM EDT
Local ID                      c2605fe4-ccca-4e51-87c8-a45d5be12632
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271882874.218:43): avc:  denied  { search } for  pid=2453 comm="consolehelper-g" name="gdm" dev=dm-2 ino=526054 scontext=staff_u:staff_r:staff_consolehelper_t:s0 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1271882874.218:43): avc:  denied  { read } for  pid=2453 comm="consolehelper-g" name="database" dev=dm-2 ino=526029 scontext=staff_u:staff_r:staff_consolehelper_t:s0 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1271882874.218:43): arch=c000003e syscall=21 success=yes exit=68719476864 a0=7fffa96b5e3b a1=4 a2=0 a3=7fffa96b23e0 items=0 ppid=1 pid=2453 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="consolehelper-g" exe="/usr/bin/consolehelper-gtk" subj=staff_u:staff_r:staff_consolehelper_t:s0 key=(null)



Hash String generated from  catchall,consolehelper-g,staff_consolehelper_t,xdm_var_run_t,dir,search
audit2allow suggests:

#============= staff_consolehelper_t ==============
allow staff_consolehelper_t xdm_var_run_t:dir search;
allow staff_consolehelper_t xdm_var_run_t:file read;

Comment 1 Daniel Walsh 2010-04-21 21:19:50 UTC
*** Bug 584571 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2010-04-21 21:21:10 UTC
*** Bug 584573 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2010-04-21 21:24:28 UTC
I will add this access, but realize most consolehelper apps will not be available to staff_t, since they require admin privs and staff_t is not an admin.

What were you trying to do?

Fixed in selinux-policy-3.7.19-5.fc13.noarch

Comment 4 Carl G. 2010-04-21 22:08:18 UTC
I have no idea...

Well, that's fine for me. I wasn't aware of that component existed until today so :)

I should look for dupes before reporting bugs too.... as a member of BugZappers i'm not really giving the best example :P setroubleshoot is pretty good at that though.

Comment 5 Fedora Update System 2010-04-26 19:51:59 UTC
selinux-policy-3.7.19-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-6.fc13

Comment 6 Fedora Update System 2010-04-27 05:49:12 UTC
selinux-policy-3.7.19-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-6.fc13

Comment 7 Fedora Update System 2010-04-28 03:06:36 UTC
selinux-policy-3.7.19-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.