Bug 584573 - SELinux is preventing /usr/bin/consolehelper-gtk "getattr" access on /var/run/gdm/auth-for-carl-VwTwsZ/database.
SELinux is preventing /usr/bin/consolehelper-gtk "getattr" access on /va...
Status: CLOSED DUPLICATE of bug 584570
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:aeb25418232...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 17:07 EDT by Carl G.
Modified: 2010-04-21 17:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 17:21:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl G. 2010-04-21 17:07:15 EDT
Summary:

SELinux is preventing /usr/bin/consolehelper-gtk "getattr" access on
/var/run/gdm/auth-for-carl-VwTwsZ/database.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by consolehelper-g. It is not expected that this
access is required by consolehelper-g and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                staff_u:staff_r:staff_consolehelper_t:s0
Target Context                system_u:object_r:xdm_var_run_t:s0
Target Objects                /var/run/gdm/auth-for-carl-VwTwsZ/database [ file
                              ]
Source                        consolehelper-g
Source Path                   /usr/bin/consolehelper-gtk
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           usermode-gtk-1.104.2-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-2.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.2-57.fc13.x86_64
                              #1 SMP Tue Apr 20 08:57:50 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 21 Apr 2010 04:47:54 PM EDT
Last Seen                     Wed 21 Apr 2010 04:47:54 PM EDT
Local ID                      4ee36341-f5e4-45f7-9b57-6a2c58d9ac2e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271882874.219:45): avc:  denied  { getattr } for  pid=2453 comm="consolehelper-g" path="/var/run/gdm/auth-for-carl-VwTwsZ/database" dev=dm-2 ino=526029 scontext=staff_u:staff_r:staff_consolehelper_t:s0 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1271882874.219:45): arch=c000003e syscall=5 success=yes exit=0 a0=5 a1=7fffa96b24d0 a2=7fffa96b24d0 a3=7fffa96b2370 items=0 ppid=1 pid=2453 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="consolehelper-g" exe="/usr/bin/consolehelper-gtk" subj=staff_u:staff_r:staff_consolehelper_t:s0 key=(null)



Hash String generated from  catchall,consolehelper-g,staff_consolehelper_t,xdm_var_run_t,file,getattr
audit2allow suggests:

#============= staff_consolehelper_t ==============
allow staff_consolehelper_t xdm_var_run_t:file getattr;
Comment 1 Daniel Walsh 2010-04-21 17:21:10 EDT

*** This bug has been marked as a duplicate of bug 584570 ***

Note You need to log in before you can comment on or make changes to this bug.