Bug 584593 - n-trig multitouch hid driver causes stuck grabs in X
n-trig multitouch hid driver causes stuck grabs in X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 575409 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 19:39 EDT by John (J5) Palmieri
Modified: 2013-03-13 00:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 07:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John (J5) Palmieri 2010-04-21 19:39:51 EDT
Description of problem:

The n-trig driver in kernel 2.6.33.x is broken.  If I accidental hit my touchscreen it will cause the left mouse button in X to get stuck due to not emitting button release events.  The only way to fix this is to exit X or float the device off the master pointer using the xinput float command.

I can confirm that the driver from Linus' 2.6.34 tree works much better.  Could we backport this or at least not build the broken driver so I can build it as a module instead of patching and rebuilding my kernel every time?  Even when we move to 2.6.34 it would be nice to have this driver as a module since the multitouch features are in heavy development.  

Version-Release number of selected component (if applicable):

2.6.33.2-57.fc13.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Boot into fedora 13 on a machine with an N-Trig Duosense touchscreen 
2. touch the screen until it grabs the left mouse button (text will be selected or the desktop selection rubber band will activate)
3. Try using the left mouse button
  
Actual results:

Left mouse button does not work.  Middle and right still work.

Expected results:

Left mouse button is released (Button Release event fires) when your finger is removed from the screen.
Comment 1 Brennan Ashton 2010-06-02 14:26:09 EDT
I have also been seeing a simmilar issue with a n-trig.  Randomly even when I am not using the touch screen the left button will get stuck. I can unstick it by taping the screen with the pen, but this happens so frequently that Fedora is bascially unusable for me. This has been an issue since early in F12 and has not changed in F13.

I basically never use the tablet or touch functions and would like to just be able to remove a module which is what I do on my own kernel build.
Comment 2 Graham Gear 2010-06-07 13:59:45 EDT
I too see this issue with a Lenovo T410s, F13, 2.6.33.5-112.fc13.i686.PAE, occurring frequently between intervals of 5 sec and 30 mins between reboots. Killing X was the only resolution to the issue.

Removing the touchscreen device (N-trig DuoSense) from X seems to resolve the issue, by hacking my rc.local with:

xinput --float "N-trig DuoSense"
Comment 3 Timothy Grondin 2010-06-07 14:16:30 EDT
*** Bug 575409 has been marked as a duplicate of this bug. ***
Comment 4 Timothy Grondin 2010-06-07 14:23:01 EDT
As another temporary workaround I've found that touching the screen right after gdm loads and then running gdm-stop at the console seems to prevent the issue from happening again. Once gdm restarts I can log in and work as normal. 

If I do it then, the touch screen works so far as moving the mouse around with your fingers. Clicking does not work by touch, but is fine as far as the actual mouse buttons go. 

I'm currently on Fedora 13 with kernel 2.6.33.5-112.fc13.x86_64. 

Please let me know if there is any other information I can provide to help resolve this issue.
Comment 5 Kyle McMartin 2010-06-09 07:19:04 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=2240462

Let me know if this helps... If the build succeeds that is.

--Kyle
Comment 6 Kyle McMartin 2010-06-09 10:41:38 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=2240475

Sorry, build failed due to kernel doc. Try this one please.
Comment 7 Timothy Grondin 2010-06-09 13:12:12 EDT
New kernel works for me. Thank you very much.
Comment 8 Kyle McMartin 2010-06-09 13:28:17 EDT
Happy to help.
Comment 9 Brennan Ashton 2010-06-09 20:18:34 EDT
+1
This is also working for me.

Note You need to log in before you can comment on or make changes to this bug.