Bug 58465 - Neat changes /etc/modules.conf in an erroneous way
Neat changes /etc/modules.conf in an erroneous way
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 09:16 EST by fred-m
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 06:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My /etc/modules.conf. I hope that helps. (1.46 KB, text/plain)
2002-03-31 22:52 EST, fred-m
no flags Details

  None (edit)
Description fred-m 2002-01-17 09:16:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
On neat, when I press the "Apply" button, or the "Yes" button on the
"Do you want to save your changes?" dialog box, it changes
/etc/modules.conf. In this process, it mangles comments and some
options in /etc/modules.conf. I attached below a diff of modules.conf
before and after neat changes it. Notice that:

1) I have some commented-out "alias 3c59x-something" entries from the
time that I was developing a patch for the 3Com 3c556 (now in the
3c59x driver). These entries were un-commented and changed into "alias
3c59x".

2) I like to have more information printed about the adapter, so I
have a "options 3c59x debug=2" line. This line disappeared.

3) I have two sets of entries for the sound configuration, for ALSA
and OSS; I leave the set for the drivers that I'm not using
commented-out. The sound-slot-0 line on the ALSA set was un-commented
(I'm not using ALSA, so its entries were commented-out; the line for
OSS was further below, so it is not in the diff). That's doubly weird:
I'm configuring the network, not sound...

[fred@polestar ~]# diff -u /etc/modules.conf.before /etc/modules.conf.after
--- /etc/modules.conf.before    Thu Jan 17 22:01:43 2002
+++ /etc/modules.conf.after     Thu Jan 17 22:13:41 2002
@@ -1,14 +1,13 @@
-#alias eth0 3c59x-556-Qk
+alias eth0 3c59x
 #options 3c59x-556-Qk debug=2
-#alias eth0 3c59x-55x-2217
+alias eth0 3c59x
 #options 3c59x-55x-2217 debug=2
-#alias eth0 andrew-3c59x
+alias eth0 3c59x
 #options andrew-3c59x debug=2
-#alias eth0 3c59x-2.2.18-pre16-1
+alias eth0 3c59x
 #options 3c59x-2.2.18-pre16-1 debug=2
 
 alias eth0 3c59x
-options 3c59x debug=2
 
 alias parport_lowlevel parport_pc
 options parport_pc io=0x378 irq=7 
@@ -21,7 +20,7 @@
 #alias snd-card-0 snd-card-intel8x0
 ## The line below makes rc.sysinit start alsa before
 ## /etc/rc.d/init.d/alsasound in Red Hat 7.0
-#alias sound-slot-0 i810_audio
+alias sound-slot-0 i810_audio
 ## OSS/Free portion - card #1
 #alias sound-service-0-0 snd-mixer-oss
 #alias sound-service-0-1 snd-seq-oss


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add the following lines to /etc/modules.conf:

#alias eth0 3c59x-556-Qk
alias eth0 3c59x
options 3c59x debug=2
#alias sound-slot-0 i810_audio

2. Run neat, and press the "Apply" button.


Actual Results:  Entries are changed (see diff above)

Expected Results:  - Commented-out entries remain commented-out
- "options 3c59x debug=2" remains

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-01-17 10:19:16 EST
Can you try the version at http://people.redhat.com/teg/neat/ ?
Comment 2 fred-m 2002-01-18 09:56:50 EST
Better yet, I tested redhat-config-network-0.9.10-2.noarch.rpm on the
updates, which according to the Changelog is 0.9.10-1 in
http://people.redhat.com/teg/neat/ 
plus "final errata version built and published".

For short, the problem persists. (There's even a new bug, see bug
58513... And I have one more, coming in next week. Please feel free to
curse me :-)
Comment 3 Harald Hoyer 2002-02-20 10:30:45 EST
Thank you!
Bug fixed in CVS
Comment 4 fred-m 2002-03-31 22:49:36 EST
Tried redhat-config-network-0.9.20-1.i386.rpm in
http://people.redhat.com/teg/neat/. The problem has been only
partially corrected. Here is the new diff. Now it's changing the
parallel port and IrDA... :-(

--- /etc/modules.conf.before    Thu Jan 17 22:01:43 2002
+++ /etc/modules.conf   Fri Mar 29 23:46:59 2002
@@ -8,10 +8,8 @@
 #options 3c59x-2.2.18-pre16-1 debug=2
 
 alias eth0 3c59x
-options 3c59x debug=2
 
 alias parport_lowlevel parport_pc
-options parport_pc io=0x378 irq=7 
 
 ## ALSA configuration
 #alias char-major-116 snd
@@ -47,7 +45,6 @@
 # IrDA
 # Warning -- this is a test
 alias irda0 nsc-ircc
-options nsc-ircc io=0x02f8 dongle_id=0x09 irq=3 dma=0 
 alias tty-ldisc-11 irtty
 alias char-major-161 ircomm-tty
 
Comment 5 fred-m 2002-03-31 22:52:05 EST
Created attachment 51587 [details]
My /etc/modules.conf. I hope that helps.
Comment 6 Harald Hoyer 2002-04-02 06:57:51 EST
ugh... found the bug... someone swapped the string.find() arguments in Conf.py :(
should be fixed in 0.9.22 and later
Comment 7 Trond Eivind Glomsrxd 2002-04-11 20:44:53 EDT
Available at http://people.redhat.com/teg/neat/
Comment 8 fred-m 2002-04-29 04:29:54 EDT
OK, I tested it under redhat-config-network-0.9.30-1 and it worked nicely
(changed only whitespace on /etc/modules.conf). Thanks!!!
(Be sure to take the correction to Red Hat 7.3... :-)

Note You need to log in before you can comment on or make changes to this bug.