Bug 58466 - Shell is not case sensitive when expanding [a-z]*
Summary: Shell is not case sensitive when expanding [a-z]*
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 59028 59038 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-17 14:25 UTC by Terry Barnaby
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 14:25:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Terry Barnaby 2002-01-17 14:25:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
If you do a "rm -fr [a-z]*" all files including those begining with
capital letters are deleted !!!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. touch a b B c
2. ls [a-z]*
3.
	

Actual Results:  a  b  B  c

Expected Results:  a  b  c

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-17 21:23:43 UTC
Sure - that's the intended behavior if you're using a case insensitive locale (which is basically anything other than C).

If you don't like it, set

LC_COLLATE=C

in /etc/sysconfig/i18n


Comment 2 Terry Barnaby 2002-01-29 09:54:30 UTC
Wow this seems like a retrograde step. Bash is largely used as a systems
programming language as well as a user command shell and one that could be
relied upon across all Unix systems back to the dawn time time (1970ish !)
Now a common feature that was used is shell scripts to distinquish between
upper case and lowercase file name sets has been broken. I found this new
feature ? when using an XFree86 script which deleted the entire file tree!


Comment 3 Bernhard Rosenkraenzer 2002-01-30 10:58:47 UTC
*** Bug 59038 has been marked as a duplicate of this bug. ***

Comment 4 Bernhard Rosenkraenzer 2002-01-30 11:18:12 UTC
*** Bug 59028 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.