Bug 59028 - filename glob broken in bash 2.05-8
filename glob broken in bash 2.05-8
Status: CLOSED DUPLICATE of bug 58466
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-29 11:15 EST by Paul Clements
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 11:20:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Clements 2002-01-29 11:15:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
When used in a shell script or when called as "bash -c",
the filename glob "*" does not work properly. A match occurs
when the case of the pathnames does not match the case in the
glob regular expression. 

Wrong:
------

adam:~# bash -c "echo /tmp/de/[A-Z]*/setup"
/tmp/de/java/setup /tmp/de/licensing/setup /tmp/de/RedHat/setup

adam:~# ls -l /tmp/de
total 448
drwxr-xr-x    2 21813    users        4096 Jan 21 17:50 array
drwxr-xr-x    2 21813    users        4096 Jan 21 17:50 java
drwxr-xr-x    2 21813    users        4096 Jan 21 17:51 licensing
drwxr-xr-x    2 21813    users        4096 Jan 21 17:51 RedHat
-r-xr--r--    1 21813    users        2730 Jan 28 12:00 setup


Right:
------
adam:~# echo /tmp/de/[A-Z]*/setup
/tmp/de/RedHat/setup


System Info:
------------
adam:~# rpm -qv bash
bash-2.05-8

adam:~# rpm -qv redhat-release
redhat-release-7.2-1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
	

Actual Results:  see above

Expected Results:  see above

Additional info:

see above
Comment 1 Bernhard Rosenkraenzer 2002-01-30 06:18:17 EST

*** This bug has been marked as a duplicate of 58466 ***
Comment 2 Paul Clements 2002-01-30 14:19:08 EST
I've read the description for bug 58466, and while setting LC_COLLATE to C does
solve my particular problem, I'm still concerned that there is a bug in either
the en_US locale or bash. To wit, the following two commands should yield
identical results (unless "a" is a special letter in en_US, which I doubt is the
case): 

adam:/tmp/de# bash -c "echo [A-Za-z]*/setup"
array/setup java/setup licensing/setup RedHat/setup

adam:/tmp/de# bash -c "echo [A-Z]*/setup"
java/setup licensing/setup RedHat/setup

adam:/tmp/de# echo $LANG
en_US


Note You need to log in before you can comment on or make changes to this bug.