Bug 58467 - Bash seems to now have a smaller limit on the number of arguments that can be passed to programs
Bash seems to now have a smaller limit on the number of arguments that can be...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 09:30 EST by Terry Barnaby
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 06:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Code demonstrating it's not a bash problem (433 bytes, text/plain)
2002-01-23 06:30 EST, Bernhard Rosenkraenzer
no flags Details

  None (edit)
Description Terry Barnaby 2002-01-17 09:30:02 EST
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. ls */*/*/* in a big tree of files
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jakub Jelinek 2002-01-22 12:00:34 EST
*** Bug 58649 has been marked as a duplicate of this bug. ***
Comment 2 Bernhard Rosenkraenzer 2002-01-23 06:30:08 EST
Created attachment 43274 [details]
Code demonstrating it's not a bash problem
Comment 3 Bernhard Rosenkraenzer 2002-01-23 06:32:01 EST
As you can see from the attached C application, the limit is enforced by glibc's
exec functions, not bash.
Call the application with parameter 32767 and it'll work, call it with 32768 and
it'll show the error message.

This limit has always been the same (if you don't believe me, try running the
test application on older releases), so I think it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.