Bug 58649 - Internal compiler error in walk_tree, at tree-inline.c:1316
Summary: Internal compiler error in walk_tree, at tree-inline.c:1316
Status: CLOSED DUPLICATE of bug 58647
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-22 10:14 UTC by Tim Waugh
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 11:06:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2002-01-22 10:14:05 UTC
Description of Problem:
g++ crashes while compiling this file with -fPIC -O1.  It doesn't happen on 
the preprocessed file, and it doesn't happen at -O0.

Version-Release number of selected component (if applicable):
gcc-3.1-0.18

How Reproducible:
100%

Steps to Reproduce:
1. Grab Omni-0.5.1-1.src.rpm.
2. rpm -bp Omni.spec
3. c++ -fPIC -O1 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -c 
OmniIJSProxy.cpp

Actual Results:
In file included from /usr/include/g++-v3/backward/strstream:51,
                 from DeviceOrientation.hpp:26,
                 from Device.hpp:39,
                 from OmniIJSProxy.hpp:25,
                 from OmniIJSProxy.cpp:30:
/usr/include/g++-v3/backward/backward_warning.h:32:2: warning: #warning This 
file includes at least one deprecated or antiquated header. Please consider 
using one of the 32 headers found in section 17.4.1.2 of the C++ standard. 
Examples include substituting the <X> header for the <X.h> header for C++ 
includes, or <sstream> instead of the deprecated header <strstream.h>. To 
disable this warning use -Wno-deprecated.
In file included from /usr/include/g++-v3/bits/locale_facets.tcc:540:
OmniIJSProxy.cpp:599: Internal compiler error in walk_tree, at tree-inline.c:
   1316
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Comment 1 Tim Waugh 2002-01-22 15:13:54 UTC
Seems to be fine with -march=i386 -mcpu=i686.


Comment 2 Jakub Jelinek 2002-01-22 17:00:40 UTC
Nevertheless, I guess it is the same bug.

*** This bug has been marked as a duplicate of 58467 ***

Comment 3 Bernhard Rosenkraenzer 2002-01-23 10:58:45 UTC
I don't see how this bug is connected to the number of possible arguments in 
bash ;) 
Guess it was made a duplicate of a wrong bug ID.

Comment 4 Jakub Jelinek 2002-01-23 11:05:43 UTC

*** This bug has been marked as a duplicate of 58647 ***

Comment 5 Tim Waugh 2002-01-23 11:06:31 UTC

*** This bug has been marked as a duplicate of 58647 ***


Note You need to log in before you can comment on or make changes to this bug.