Bug 584687 - Installing docked laptop
Installing docked laptop
Status: CLOSED DUPLICATE of bug 585111
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jérôme Glisse
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 03:58 EDT by Taunus
Modified: 2010-04-28 05:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 05:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with drm.debug=15 (122.71 KB, text/plain)
2010-04-26 02:14 EDT, Taunus
no flags Details
Xorg.0.log (101.64 KB, text/plain)
2010-04-26 02:15 EDT, Taunus
no flags Details
/var/log/messages (80.52 KB, text/plain)
2010-04-26 02:44 EDT, Taunus
no flags Details

  None (edit)
Description Taunus 2010-04-22 03:58:33 EDT
Description of problem:
When installing docked laptop the focus moves from external display to internal even when it is closed at the time when graphical installation kicks in.


Version-Release number of selected component (if applicable):


How reproducible:
Set Thinkpad T400 bios settings to "discrete graphics" and os detection for switcahble graphics to "no".

Steps to Reproduce:
1. Start installing rhel 6 beta
2. answer the keyboard etc questions
3. When graphical install starts, no image on external display. Opening the laptop display will show image on laptop.
  
Actual results:
Image does not show on external display through the installation process when laptop lid closed.

Expected results:
Image stays on external display throuh the installation process when laptop lid closed.

Additional info:
Display graphics Ati Mobility Radeon 3470
Comment 2 RHEL Product and Program Management 2010-04-22 06:59:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Taunus 2010-04-23 02:40:24 EDT
The same things happens when OS boots up for the first time and OS wants to know username etc.
Comment 4 Matěj Cepl 2010-04-23 11:42:05 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

After the second bootup everything works as expected?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Taunus 2010-04-26 02:14:12 EDT
After the second boot it does not work as expected. It works like described in bug https://bugzilla.redhat.com/show_bug.cgi?id=585111

No /etc/X11/xorg.conf at all.
Comment 6 Taunus 2010-04-26 02:14:58 EDT
Created attachment 409078 [details]
dmesg with drm.debug=15
Comment 7 Taunus 2010-04-26 02:15:29 EDT
Created attachment 409079 [details]
Xorg.0.log
Comment 8 Taunus 2010-04-26 02:44:48 EDT
Created attachment 409095 [details]
/var/log/messages
Comment 10 Jérôme Glisse 2010-04-28 05:14:27 EDT

*** This bug has been marked as a duplicate of bug 585111 ***

Note You need to log in before you can comment on or make changes to this bug.