Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585111 - docked laptop - wrong display
docked laptop - wrong display
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jérôme Glisse
desktop-bugs@redhat.com
card_R600/mM
: Triaged
: 584687 585113 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 03:04 EDT by Taunus
Modified: 2010-11-15 09:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with drm.debug=15 (122.71 KB, text/plain)
2010-04-26 01:57 EDT, Taunus
no flags Details
Xorg.0.log the right one (101.64 KB, text/plain)
2010-04-26 02:00 EDT, Taunus
no flags Details

  None (edit)
Description Taunus 2010-04-23 03:04:57 EDT
Description of problem:
Booting up a laptop with lid closed ends up with a login screen to a closed laptop screen. External display has desktop "left of" the login screen.

Version-Release number of selected component (if applicable):
rhel 6 beta

How reproducible:
Boot laptop when docked and laptop lid closed

Steps to Reproduce:
1. Insert laptop to a docking station with external display
2. Turn on the laptop
3. Wait and see
  
Actual results:
Closed display is used as the main display

Expected results:
External display is used as the main display

Additional info:
Ati Mobility Radeon HD 3470
Comment 1 Taunus 2010-04-23 03:23:09 EDT
There is a duplicate bug I accidentally created #585113 due to "proxy error" or something. I thought the first one didn't go through...
Comment 3 RHEL Product and Program Management 2010-04-23 05:02:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jérôme Glisse 2010-04-23 06:36:51 EDT
*** Bug 585113 has been marked as a duplicate of this bug. ***
Comment 5 Jérôme Glisse 2010-04-23 06:37:57 EDT
Please boot with drm.debug=15 and attach dmesg + xorg log when the laptop is docked.
Comment 6 Taunus 2010-04-26 01:56:36 EDT
dmesg.txt and Xorg.0.log attached
Comment 7 Taunus 2010-04-26 01:57:22 EDT
Created attachment 409069 [details]
dmesg with drm.debug=15
Comment 9 Taunus 2010-04-26 02:00:32 EDT
Created attachment 409072 [details]
Xorg.0.log the right one
Comment 11 Jérôme Glisse 2010-04-28 05:14:28 EDT
*** Bug 584687 has been marked as a duplicate of this bug. ***
Comment 12 Jérôme Glisse 2010-04-30 12:56:00 EDT
Please give the output of :
cat /proc/acpi/button/lid/LID/state

When the laptop is docked and lid closed and external screen active.

Thanks.
Comment 13 Taunus 2010-05-03 05:27:05 EDT
cat /proc/acpi/button/lid/LID/state
state: closed
Comment 15 Aristeu Rozanski 2010-05-26 15:18:35 EDT
Patch(es) available on kernel-2.6.32-30.el6
Comment 18 Taunus 2010-06-03 02:05:42 EDT
Can I get the kernel from somewhere?
Comment 19 Taunus 2010-07-01 08:30:27 EDT
With rhel 6 beta 2 it works as it should.
Comment 20 releng-rhel@redhat.com 2010-11-15 09:24:59 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.