Bug 584694 - SELinux is preventing /usr/bin/pulseaudio "read" access on 5a4f8fd14189c6892198d366442284e2-runtime.
Summary: SELinux is preventing /usr/bin/pulseaudio "read" access on 5a4f8fd14189c...
Keywords:
Status: CLOSED DUPLICATE of bug 584698
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b35f8f47d39...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 08:23 UTC by Robert Townley
Modified: 2010-04-26 20:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-22 11:37:19 UTC
Type: ---


Attachments (Terms of Use)

Description Robert Townley 2010-04-22 08:23:56 UTC
Summary:

SELinux is preventing /usr/bin/pulseaudio "read" access on
5a4f8fd14189c6892198d366442284e2-runtime.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:pulseaudio_t:s0
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                5a4f8fd14189c6892198d366442284e2-runtime [
                              lnk_file ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.21-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux Eye40.eceo.us 2.6.32.11-99.fc12.i686.PAE #1
                              SMP Mon Apr 5 16:15:03 EDT 2010 i686 i686
Alert Count                   5
First Seen                    Thu 22 Apr 2010 02:07:12 AM CDT
Last Seen                     Thu 22 Apr 2010 02:37:16 AM CDT
Local ID                      ef063d96-d359-403b-b9de-9988386294bb
Line Numbers                  

Raw Audit Messages            

node=Eye40.eceo.us type=AVC msg=audit(1271921836.560:85): avc:  denied  { read } for  pid=3147 comm="pulseaudio" name="5a4f8fd14189c6892198d366442284e2-runtime" dev=dm-0 ino=135345 scontext=unconfined_u:system_r:pulseaudio_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=lnk_file

node=Eye40.eceo.us type=SYSCALL msg=audit(1271921836.560:85): arch=40000003 syscall=85 success=yes exit=23 a0=b6b00588 a1=b6b004c0 a2=63 a3=64 items=0 ppid=3142 pid=3147 auid=500 uid=494 gid=475 euid=494 suid=494 fsuid=494 egid=475 sgid=475 fsgid=475 tty=pts0 ses=2 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=unconfined_u:system_r:pulseaudio_t:s0 key=(null)



Hash String generated from  catchall,pulseaudio,pulseaudio_t,var_lib_t,lnk_file,read
audit2allow suggests:

#============= pulseaudio_t ==============
allow pulseaudio_t var_lib_t:lnk_file read;

Comment 1 Daniel Walsh 2010-04-22 11:37:19 UTC

*** This bug has been marked as a duplicate of bug 584698 ***


Note You need to log in before you can comment on or make changes to this bug.