Bug 584698 - SELinux is preventing /usr/bin/pulseaudio "read write" access on /var/lib/mpd/.esd_auth.
SELinux is preventing /usr/bin/pulseaudio "read write" access on /var/li...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:9affe690500...
:
: 584694 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 04:27 EDT by Robert Townley
Modified: 2010-04-22 07:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 07:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Townley 2010-04-22 04:27:18 EDT
Summary:

SELinux is preventing /usr/bin/pulseaudio "read write" access on
/var/lib/mpd/.esd_auth.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:pulseaudio_t:s0
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                /var/lib/mpd/.esd_auth [ file ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.21-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.i686.PAE #1
                              SMP Mon Apr 5 16:15:03 EDT 2010 i686 i686
Alert Count                   4
First Seen                    Thu 22 Apr 2010 02:07:12 AM CDT
Last Seen                     Thu 22 Apr 2010 02:37:16 AM CDT
Local ID                      e30e48ec-ae0b-44eb-a2cd-3b6659e372f1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271921836.583:92): avc:  denied  { read write } for  pid=3150 comm="pulseaudio" name=".esd_auth" dev=dm-0 ino=171243 scontext=unconfined_u:system_r:pulseaudio_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271921836.583:92): avc:  denied  { open } for  pid=3150 comm="pulseaudio" name=".esd_auth" dev=dm-0 ino=171243 scontext=unconfined_u:system_r:pulseaudio_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1271921836.583:92): arch=40000003 syscall=5 success=yes exit=15 a0=8349348 a1=8142 a2=180 a3=0 items=0 ppid=3146 pid=3150 auid=500 uid=494 gid=475 euid=494 suid=494 fsuid=494 egid=475 sgid=475 fsgid=475 tty=(none) ses=2 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=unconfined_u:system_r:pulseaudio_t:s0 key=(null)



Hash String generated from  catchall,pulseaudio,pulseaudio_t,var_lib_t,file,read,write
audit2allow suggests:

#============= pulseaudio_t ==============
#!!!! The source type 'pulseaudio_t' can write to a 'file' of the following types:
# pulseaudio_home_t, user_fonts_cache_t, user_tmp_t, xdm_tmp_t, pulseaudio_var_lib_t, pulseaudio_var_run_t, user_home_type, gnome_home_type, anon_inodefs_t, user_tmpfs_t, root_t, nfs_t

allow pulseaudio_t var_lib_t:file { read write open };
Comment 1 Daniel Walsh 2010-04-22 07:36:49 EDT
restorecon -R -v /var/lib/pulse

Should fix.

This looks like it got mislabeled for some reason.


If it happens again please reopen the bug.
Comment 2 Daniel Walsh 2010-04-22 07:37:19 EDT
*** Bug 584694 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.