Bug 58476 - Installing AbiWord RPM screws up fonts for other apps (eg Galeon)
Installing AbiWord RPM screws up fonts for other apps (eg Galeon)
Status: CLOSED DUPLICATE of bug 18855
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 14:07 EST by William Shubert
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 14:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shubert 2002-01-17 14:07:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
The AbiWord system installs fonts with incorrect names. For example, it installs
a font called "abisource-arial" that is not arial, etc. Other progams, looking
for a font called "arial", find the horrible looking abiword version instead of
the good looking "ult1mo" version because abisource comes before ult1mo. Thus,
having Abiword installed makes many other applications look terrible.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -i abiword*
2.galeon http://www.salon.com/ (many other sites have this problem too)
3.Click on an article

Actual Results:  I saw incredibly ugly, nearly unreadable text.

Expected Results:  I should have seen some nice neat looking text.

Additional info:

The abiword people know of this bug, but consider it unimportant and have
postponed fixing it. To me, this bug is unbelievable, that they would include
fonts with incorrect names that confuse other apps which are using fonts
properly. I thought Red Hat 7.2 had unusable fonts for web browsing until I
found out that by simply removing abiword things got better. At the very least
abiword should probably not be installed by default.
Comment 1 Bernhard Rosenkraenzer 2002-01-18 13:29:10 EST

*** This bug has been marked as a duplicate of 18855 ***

Note You need to log in before you can comment on or make changes to this bug.