Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 584833 - Input problems on Thinkpad T42
Summary: Input problems on Thinkpad T42
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 14:33 UTC by Owen Taylor
Modified: 2010-11-24 21:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-24 21:43:12 UTC
Type: ---


Attachments (Terms of Use)

Description Owen Taylor 2010-04-22 14:33:27 UTC
With the upgrade from 1.8.0-6 to 1.8.0-7, I suddenly started having my cursor jump around when trying to navigate with the Trackpoint on my T42. This made the desktop unusable. Downgrading made the problem go away. 

My guess was that the problem was that some sort of suppression of events from the trackpad got lost, so the events were coming from me brushing against the trackpad or from dirt on the trackpad, but I didn't investigate long enough to conclusively say that was the probpem.

Comment 1 Michal Schmidt 2010-04-22 14:43:24 UTC
Do you use compiz? Does it work better if you disable it?

Comment 2 Owen Taylor 2010-04-22 14:52:29 UTC
This was with normal metacity, both in gdm and logged into the session. 

(I'd have trouble figuring out how compiz could cause something like this - compiz doesn't have any say in where the mouse cursor appears.)

Comment 3 Michal Schmidt 2010-04-22 14:54:09 UTC
I was thinking that compiz could somehow cause a very slow refresh of the screen which might seem like the cursor was jumping. But nevermind.

Comment 4 Rob Whalley 2010-04-22 17:28:37 UTC
Same problem on Samsung NC10 netbook. Check out: https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.2.2-3.fc13?_csrf_token=e2e11a7e9fadfa0f43a56541a7d69446b5e2159c - was pushed to stable yesterday but looks like it hasn't hit the mirror I'm using yet. 

The following should serve as a workaround for now:
yum localinstall http://kojipkgs.fedoraproject.org/pack/xorg-x11-drv-synaptics/1.2.2/3.fc13/i686/xorg-x11-drv-synaptics-1.2.2-3.fc13.i686.rpm --nogpgcheck

...solved the mouse cursor jumping issue for me.

I'm guessing that the issue is caused by the X server using /etc/xorg.conf.d instead of /etc/X11/xorg.conf.d to store the configuration files - see bug 582468:
https://bugzilla.redhat.com/show_bug.cgi?id=582468

Comment 5 Adel Gadllah 2010-04-23 20:33:01 UTC
(In reply to comment #4)
> Same problem on Samsung NC10 netbook. Check out:
> https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.2.2-3.fc13?_csrf_token=e2e11a7e9fadfa0f43a56541a7d69446b5e2159c
> - was pushed to stable yesterday but looks like it hasn't hit the mirror I'm
> using yet. 
> 
> The following should serve as a workaround for now:
> yum localinstall
> http://kojipkgs.fedoraproject.org/pack/xorg-x11-drv-synaptics/1.2.2/3.fc13/i686/xorg-x11-drv-synaptics-1.2.2-3.fc13.i686.rpm
> --nogpgcheck
> 
> ...solved the mouse cursor jumping issue for me.
> 
> I'm guessing that the issue is caused by the X server using /etc/xorg.conf.d
> instead of /etc/X11/xorg.conf.d to store the configuration files - see bug
> 582468:
> https://bugzilla.redhat.com/show_bug.cgi?id=582468    

Yeah, the result was that evdev was driving the touchpads which well ... it can't do very good ;)

The updated xorg-x11-drv-synaptics indeed fixes it.

Comment 6 Bug Zapper 2010-07-30 11:26:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Magnus Glantz 2010-11-24 21:43:12 UTC
House-keeping. 

xorg-x11-drv-synaptics-1.3.0-1 in current, consensus seems to be that this is a fixed issue. If that is not the case, please feel free to re-open the bug. Thank you.

Now closing.


Note You need to log in before you can comment on or make changes to this bug.