Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
For bugs related to Red Hat Enterprise Linux 5 product line. The current stable release is 5.10. For Red Hat Enterprise Linux 6 and above, please visit Red Hat JIRA https://issues.redhat.com/secure/CreateIssue!default.jspa?pid=12332745 to report new issues.

Bug 584912

Summary: iscsi hangs/errors when shutting down
Product: Red Hat Enterprise Linux 5 Reporter: Bryn M. Reeves <bmr>
Component: iscsi-initiator-utilsAssignee: Mike Christie <mchristi>
Status: CLOSED DUPLICATE QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 5.5CC: bdonahue, coughlan, jeff_burdette, jkurik, jwest, kzhang, mchristi, moshiro, pep
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-04 19:08:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Bryn M. Reeves 2010-04-22 17:32:50 UTC
Description of problem:
The fix for bug 511271 deleted the lines in the iscsi init script that disabled network shutdown:

> This is the diff of two versions of /etc/init.d/iscsid:
> $ diff iscsid.iscsi-initiator-utils-6.2.0.871-0.14.el5.i386.rpm \
> iscsid.6.2.0.871-0.10.el5 
> 
> 18a19,26
> > 	echo -n $"Turning off network shutdown. "
> > 	# we do not want iscsi or network to run during system shutdown
> > 	# incase there are RAID or multipath devices using
> > 	# iscsi disks
> > 	chkconfig --level 06 network off
> > 	rm /etc/rc0.d/*network
> > 	rm /etc/rc6.d/*network
> >    

This was done to avoid a conflict with readonly root environments but causes a regression of bug 209523, (I/O errors and hangs when shutting down a system using iSCSI).

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.871-0.16.el5

How reproducible:
100%

Steps to Reproduce:
1. Configure a system to use iscsi-initiator-utils to access storage
2. Shutdown the host while the iscsi storage is in use

  
Actual results:
Network shutdown scripts shut down the iSCSI interfaces before file systems are unmounted and the iSCSI service itself is shut down, leading to I/O errors.

Expected results:
System should not hang or produce I/O errors on shutdown.

Additional info:

Comment 4 Bryn M. Reeves 2010-05-27 09:11:58 UTC
Fix component.

Comment 5 Mike Christie 2010-05-27 23:24:51 UTC
This is a s dup of
https://bugzilla.redhat.com/show_bug.cgi?id=583218

Which bz do you want to use? The other one is not setup for z stream yet.

The fix is not easy when also supporting boot and existing solutions and the chkconfig read-only issue.

Comment 6 Mike Christie 2010-05-27 23:27:02 UTC
One question.

Should I be able to just run "chkconfig --level 06 network off" in the rpm install section? Then on later boots the network shutdown should be off or is there something that resets that on each boot?

Comment 11 Mike Christie 2010-07-04 19:08:11 UTC

*** This bug has been marked as a duplicate of bug 583218 ***