Bug 58493 - .spec file portability problem
Summary: .spec file portability problem
Status: CLOSED DUPLICATE of bug 58496
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-18 03:19 UTC by R P Herrold
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 03:19:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2002-01-18 03:19:48 UTC
The change in the new specfile for update pine-4.44-1.72.0.src.rpm has a couple
of portability problems.

From: Chris Adams <cmadams@hiwaay.net

This is the primary problem I've had.  For example, the RHL 7.2 pine RPM
had:

for n in pine pico pilot; do
    install -c -m 755 -s bin/$n $RPM_BUILD_ROOT/usr/bin/$n
done

For the errata, someone decided it was "better" to do:

install -m 755 bin/{pine,pico,pilot,rpdump,rpload} $RPM_BUILD_ROOT/usr/bin/

Why?  There is no good reason not to use the more portable loop.

And they didn't fix the real problem: the use of /usr/bin instead of
%{_prefix}/bin or even better %{_bindir}. :-)

----------------------

This thread from the rpm-list on Date: Thu, 17 Jan 2002 21:03:27 -0600

Comment 1 R P Herrold 2002-01-18 03:28:03 UTC
Bugzilla 'hickupped ' -- close one of the dupes

*** This bug has been marked as a duplicate of 58496 ***


Note You need to log in before you can comment on or make changes to this bug.