Bug 58496 - .spec file portability problem
.spec file portability problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 58493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 22:21 EST by R P Herrold
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 22:28:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-01-17 22:21:09 EST
The change in the new specfile for update pine-4.44-1.72.0.src.rpm has
introduced a couple of portability problems.

From: Chris Adams <cmadams@hiwaay.net

This is the primary problem I've had.  For example, the RHL 7.2 pine RPM
had:

for n in pine pico pilot; do
    install -c -m 755 -s bin/$n $RPM_BUILD_ROOT/usr/bin/$n
done

For the errata, someone decided it was "better" to do:

install -m 755 bin/{pine,pico,pilot,rpdump,rpload} $RPM_BUILD_ROOT/usr/bin/

Why?  There is no good reason not to use the more portable loop.

And they didn't fix the real problem: the use of /usr/bin instead of
%{_prefix}/bin or even better %{_bindir}. :-)

----------------------

This thread from the rpm-list on Date: Thu, 17 Jan 2002 21:03:27 -0600
Comment 1 R P Herrold 2002-01-17 22:27:58 EST
*** Bug 58493 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2002-01-18 03:04:48 EST
Yes, I made that change.  It builds fine on all releases of Red Hat Linux
that I have built it on.  I'm not sure I understand the problem exactly.

Not portable to what exactly?

/usr/bin is not "better".  I'm not sure the goals of Red Hat Linux
coincide with whatever it is that whoever is trying to accomplish.

%{_bindir} is the proper location for the binaries to be placed in,
and it is exactly where they are.  I have no idea where the %{_prefix}
comes from as that string is found nowhere in the pine spec file.

%files
%defattr(-,root,root)
%doc README CPYRIGHT doc/*.txt doc/pine-ports doc/tech-notes
%doc doc/mailcap.unx imap/docs/bugs.txt
%{_bindir}/pine
%{_bindir}/pine-spellcheck
%{_bindir}/pico
%{_bindir}/pilot
%{_bindir}/rpdump
%{_bindir}/rpload
%{_mandir}/man1/pico.1*
%{_mandir}/man1/pine.1*
%{_mandir}/man1/pilot.1*
%{_mandir}/man1/rpdump.1*
%{_mandir}/man1/rpload.1*
%attr(0644,root,root)   %config /etc/pine.conf
%attr(0644,root,root)   %config /etc/pine.conf.fixed
 
%if %{with_gpgpine}
%attr(0755, root, root) %{_bindir}/pinepgpgpg-install
%attr(0755, root, root) %{_bindir}/pinegpg-install
%attr(0755, root, root) %{_bindir}/pinegpg
%attr(0755, root, root) %{_bindir}/gpg-sign
%attr(0755, root, root) %{_bindir}/gpg-sign+encrypt
%attr(0755, root, root) %{_bindir}/gpg-encrypt
%attr(0755, root, root) %{_bindir}/gpg-check
%endif

Note You need to log in before you can comment on or make changes to this bug.