Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 585031 - ValueError: arg 1 must be a StorageDevice instance
ValueError: arg 1 must be a StorageDevice instance
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 19:19 EDT by John Reiser
Modified: 2012-02-09 16:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-09 16:28:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug traceback saved by anaconda, gzipped (34.46 KB, application/x-gzip)
2010-04-22 19:19 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2010-04-22 19:19:40 EDT
Created attachment 408465 [details]
debug traceback saved by anaconda, gzipped

Description of problem: Installer traceback during Custom partition editing.


Version-Release number of selected component (if applicable):
anaconda-14.4

How reproducible: haven't tried


Steps to Reproduce:
1. fresh install of rawhide for Fedora 14 from DVD
2. basic disks, custom configuration
3. select existing ext4 partition; cannot Edit because of bug 582083.
4. switch to shell on VT2, use fdisk to change partition type to 0 (Empty).
5. switch back to VT6, click Back button (causes Finding storage devices and re-shows dialog with Custom configuration selected)
6. click Next,  to get graphical partition editor
7. try to Create partition from Free space created by step 4.
  
Actual results: traceback with ValueError: arg 1 must be a StorageDevice instance


Expected results: Free space available for assignment to new partition.


Additional info:
Comment 1 John Reiser 2010-04-22 19:20:12 EDT
anaconda 14.4 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/pyanaconda/storage/deviceaction.py", line 141, in __init__
    raise ValueError("arg 1 must be a StorageDevice instance")
  File "/usr/lib64/python2.6/site-packages/pyanaconda/storage/deviceaction.py", line 200, in __init__
    DeviceAction.__init__(self, device)
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/partition_dialog_gui.py", line 220, in run
    actions.append(ActionCreateDevice(request))
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/partition_gui.py", line 1674, in editPartition
    actions = parteditor.run()
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/partition_gui.py", line 1560, in createCB
    self.editPartition(device, isNew = True)
ValueError: arg 1 must be a StorageDevice instance
Comment 2 Chris Lumens 2010-05-26 16:59:40 EDT
Is this at all reproducible?  I don't believe anyone here has seen this bug before.
Comment 3 John Reiser 2010-05-26 23:18:10 EDT
Attempt to reproduce was blocked by bug 596585.
Comment 4 Bug Zapper 2010-07-30 07:26:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chris Lumens 2012-02-09 16:28:26 EST
If you see this again in F17 alpha, please reopen this bug.  I've not seen any duplicates of it so I believe it to be fixed.

Note You need to log in before you can comment on or make changes to this bug.