Bug 585053 - STDOUT does not work with many commands in single-user mode
STDOUT does not work with many commands in single-user mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Yulia Kopkova
:
: 613803 (view as bug list)
Depends On:
Blocks: 614088
  Show dependency treegraph
 
Reported: 2010-04-22 21:37 EDT by Norman
Modified: 2010-11-10 15:40 EST (History)
4 users (show)

See Also:
Fixed In Version: initscripts-9.03.11-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 614088 (view as bug list)
Environment:
Last Closed: 2010-11-10 15:40:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman 2010-04-22 21:37:06 EDT
Description of problem:
when debugging issues in single-user mode, STDOUT does not appear on console.

Version-Release number of selected component (if applicable):
RHEL 6.0 Beta 1

How reproducible:
100%

Steps to Reproduce:
1. boot, changing 'rhgb quiet' to 'single' at the grub menu
2. at shell, type 'ifconfig -a' or 'ip link show' -> no output, but shell prompt returned
3.
  
Actual results:
output not displayed

Expected results:
STDOUT to be displayed on console without any need for redirection

Additional info:
'ifconfig -a | more' or 'ifconfig -a 1> /dev/console' does show output on console, but 'ifconfig -a > /tmp/file' does not populate /tmp/file.

my grub.conf is the one installed by the installer:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_morris-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sdc
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux 6 (2.6.32-19.el6.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.32-19.el6.i686 ro root=/dev/mapper/vg_morris-lv_root rd_LVM_LV=vg_morris/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.32-19.el6.i686.img
Comment 2 RHEL Product and Program Management 2010-04-22 22:54:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Bill Nottingham 2010-06-29 13:01:33 EDT
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=f738fe3f561fbc53f356f10f8f77d5e5f3b86d84

Policy will need modified to label /sbin/sushell appropriately. (Using the same
context as /sbin/sulogin works in a quick test, but may have unintended
consequences.)

Will be in 9.03.11-1.
Comment 9 Bill Nottingham 2010-07-13 12:32:03 EDT
*** Bug 613803 has been marked as a duplicate of this bug. ***
Comment 11 releng-rhel@redhat.com 2010-11-10 15:40:09 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.